• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Samsung Galaxy S6 How do I stop my text messages from displaying a preview in the notification bar?

That is not the right location as we can see on the very short video on my comment. It does disable notifications on the lock screen but not pop-ups on the home screen. Pop-ups is the key word.
Thank you all for your advice, time and effort. However, none of these solutions work. The name of the contact and the message details are still appearing on the status bar. I have turned off the notifications from the lock screen, I clicked hide info now it just says new message. I am trying to figure out how to make it say just new message on my status bar (notification panel) not the details.
Problem is message details ie name's and content in notification bar on lock screen, my solution will work pop ups can also be disabled but that doesn't affect lock screen nor is it mentioned in initial question or concluding question.
So settings, sounds notifications, notifications on lock screen, select hide contents. I now get notification in lock screen and status bar saying 1 new message, no name no content. To disable pop ups is a different setting bug easy enough to do as everyone has pointed out but sounds like you already did that. Let me know how this works for you.
 
Last edited:
Upvote 0
I just got the Samsung Galaxy S6 today. I upgraded from a S4. My text keep showing a preview in the status bar & I can't figure out how to turn it off. Does anyone know how to fix this? Its important because I use my phone for work & can't have something silly showing up at work. :(


I was having the same problem. In order for this to not happen, you must have your phone in a particular lock mode, meaning your screen lock type cannot be "swipe". If it is in a lock mode, once you choose one of the modes, a screen will pop up asking you how do you want to see your notifications on the lock screen and there you can choose hide content. The message will still, however, show it's full content while you are in your phone. I am attaching the samsung manual if you need further help. That's how I found it. Hope this helps!
 

Attachments

  • USC_SM-G920R4_-Galaxy-S6_ENG_UM_LL_OCB_R6.pdf
    1.7 MB · Views: 428
Upvote 0
Hi I had the same problem BUT FOUND THE ANSWER at long last. No more pop ups are people able to see the message on the top of the screen.

go to Settings>Applications>Application manager>Downloaded>Then app you want>Then un-tick the box "show notifications"
THIS WILL WORK and will still show you that you have a message with out any name or message popping up.

ive put this on another part of the forum but thought best to show it here too.
 
Upvote 0
Thank you! But this unfortunately didn't notify that I even had a message, I have randomly unlock my phone and check manually. I've basically gotten used to it by now, but I'd love to turn it off. QUOTE="snakedoc11, post: 6987760, member: 1849476"]Hi I had the same problem BUT FOUND THE ANSWER at long last. No more pop ups are people able to see the message on the top of the screen.

go to Settings>Applications>Application manager>Downloaded>Then app you want>Then un-tick the box "show notifications"
THIS WILL WORK and will still show you that you have a message with out any name or message popping up.

ive put this on another part of the forum but thought best to show it here too.[/QUOTE]
 
Upvote 0
I agonized with i think what is the problem you are dealing with
in messages > (3 dots in the corner) > settings > Notifications (yes - i get that it says on) > pop-up display
un check that and you should still get text message notifications and not the on screen pop ups your trying to get around - hope this helps :)
 
Upvote 0
I just got the Samsung Galaxy S6 today. I upgraded from a S4. My text keep showing a preview in the status bar & I can't figure out how to turn it off. Does anyone know how to fix this? Its important because I use my phone for work & can't have something silly showing up at work. :(

Ive figured it out i believe. if you go to settings>Lock screen and security>Screen lock type> pick pattern>draw your pattern> then it gives you some options. one of them is hide content. You get popups on who texted you but it doesnt show the message itself. it only shows the name of the person who texted you. hope this helps.
 
Upvote 0
I use the app NEXT SMS Vs the original messaging and withe this app I was able to do what your asking for. If you choose to download it to solve your problem goto SETTINGS>NOTIFICATIONs> click off! That will stop messages from popping up on your phone, and set it to where it can only be viewed if you click on the app itself.

& it also comes with a feature called PRIVATE BOX which sounds like it would come in handy since you use your phone for work. With private box you can have all your messages from family and friends goto your private box and the messages ull only show by you typing in a code to unlock the messages.


OR! If you want your messages to pop up but just show NEW MESSAGE Vs what the text says go to SETTINGS> NOTIFICATION SETTINGS> PRIVATE MODE "ON". and that ull still show you have a message but won't show what it's about........


And if you downloaded the app and try this it'll work for the original messaging & the app #PROBLEM SOLVED!
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones