• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root "SD card blank or has unsupported file system"


Dec 25, 2013
So I recently got a 64 gb micro SD for my Kyocera Event. It is a Sandisk Ultra, the type specifically advertised as being for the event.
After first inserting it, I got this error and the event offered to format it. I did, but the error persisted. I then formatted the card in windows, first with the windows utility and then with the SD association program.
The card still does not work in my Event; I get the same error.
The card does store information from the computer with no problem. In addition, I have a 2 gb SD card that works fine in the event, so I tried to copy and paste all the data from it into the 64 gb card. The card still shows up as blank.
I thought there might be a problem with the phone's software, so I backed up and reset the phone. Still nothing.
I have to be missing something obvious. Help?

Update: I formatted the card in FAT32, and this error went away. However, the card still will not mount.


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.