• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help SOLVED - Root/Superuser problems

chrisdude70

Newbie
Aug 18, 2010
46
3
SOLVED

After I posted this, I thought, ok, ill try one last reboot and give it another go...

What do you know, it worked...
I'm not sure what I did, but it solved the problems ive been having for the last few weeks. Gotta love messing with it until it works.
------------------------------------------
Hey,

Im having some problems with my x10i.

It is running a generic 2.1 rom. Latest update.

Busybox is installed at 1.15 but I want to update to 1.17. When I try it says I am not NAND unlocked. I have no idea what this means.

When I try to use Root Explorer it says that it is unable to obtain root access because of an issue with super user.

xRecovery does not install because it does not have write access.
I tried to manually install and it still does not run.

I have tried rooting with several methods, all of which tell me have been successful, as well as busybox.

This was a problem before and after the multitouch update.

Any help would be very, very, very welcome.

Thanks.
 

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones