• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

This not the Droid (Turbo 2) I was looking for...


Aug 10, 2019
Hi all, I have a Droid Turbo 2 that is not reading a class 10 16 or 32G msd card. I have read through a lot of these forums, and have yet to find something that works. I have tried rebooting my phone in safe mode, cleared cached data from Settings>Storage>>Internal Shared Storage. Nothing. Tried turning debugging off and on, the same. Made sure that the USB option was set to MTP. Tried putting a piece of tape on the back to life it in case it wasn’t making contact. Nothing again. When I look either on the screen, it doesn't have a message, it just indicates that there isn't a card inserted. Also, when I try to hook it up to my Mac, Android file transfer says "Can't access device storage -- Make sure your device is unlocked and "File Transfer" or "MTP" mode is selected." It's on MTP. Zip. I just brought that up in case they might be related. I’m really lost here, guys. Does anyone have any other ideas? Please help!
Does or has the phone worked with any SD cards at all, and not just the Class 10 high speed types?
Hi Mike! SORRY it took me so long to get back to you, I overlooked your post! To answer, I've tried 3, only 1 of which was a class 10. I would really like to get this fixed as I bought the phone from Amazon and the seller has not been great about communicating with me. I have looked through a lot of forums and this seems to be a common problem with this device...
Thanks again for replying!
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.