• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Unable to download from Market after 2.1 update


May 15, 2010
After upgrading my Moment to 2.1, I can no longer download apps from Android Market. I can select to download an app, it says starting download, then quickly indicates "download unsuccessful." Prior to my upgrade it was working fine. All my account info is as it was before and has properly synced etc.

Anyone else having this issue?


I'm having the same problem with my moment. I took it to sprint because I couldn't find my usb cord. I downloaded a ton of apps for a few hours after that, but then haven't been able to successfully download one for a day or so.

I've tried using wifi and rebooting, nothing works. I still have data connection and everything else. Really getting annoyed with this. What rom should I flash it with after rooting?
Upvote 0
I had the same problem with getting apps from the market place before and after the update. I updated my Profile and the PRL. Sometimes it would say that there was a connection error. But I did it again and again till it updated. Only took a couple of times. Then I rebooted and it would work. If it didn't I shut my phone off for a bout half and hour and then tried it. It worked. And another time I gave up and the next morning it worked. I had taken it to Sprint 3 times. The tech told me it was the PRL. you have to update it. So I do and that usually fixes it.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.