• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Wi-Fi Connects But Browsing Limited

I've looked all over this forum and others and haven't found anyone with this issue. Got my Droid Eris last week and love it so far. When I use Wi-Fi it finds my router and connects with no problems. I open browser and can go to Google.com, do searches from there, etc. and everything works fine and pages load quickly as long as I stay on Google.com. But when I try any other site they either never load ("web page not available") or they take several minutes to load.

Browser works fine on all sites when on 3G. I tried Wi-Fi with 3G turned-on and turned-off, but same results. Tried clearing browser cache, deleted cookies, etc.

I'm stumped...I can't think of anything that would prevent non-Google sites from working only when I'm using Wi-Fi. Any suggestions?

Oddly enough, I ran into a similar problem today, and have some experience to share...

I have an older Belkin G+MIMO wireless router got for pennies, and decided to hook it up today. Used their setup CD and got it going. However, it would drop the line repeatedly, both wired and WiFi. Resets only made it worse.

Finally, I gave in and called Belkin. Turns out the setup CD is pretty useless, but the techs (all three of them) seemed to have a good idea of what settings to give me. After their call, the WiFi web access is faster, more robust, and still secured. Not an intuitive solution at all, never would've gotten it with their online FAQs...

Maybe not an exact answer to your problem, but something to consider...
Upvote 0
Possibly a DNS issue? Try using OpenDNS IPs in your router config and see what happens. Could be what mode the router is running in as well? Someone on the forums was complaining they couldn't browse when the router was running in G only mode versus mixed mode or something like that. Does the marketplace work correctly using Wifi? If so have you tried installing another browser and using that?
Upvote 0
Thanks for your suggestions. The problem is not the connection to my WAP; the phone shows connected, it has a valid IP address assigned, and I can easily/quickly browse Google (just no other websites). Gmail and Market work, too, but other apps/widgets like weather, stocks, POP mail, do not. So, it seems to prefer Google-based items only.

Router is set to G-mode only (not mixed). I also tried using the Dolphin browser but same results. I turned-off all encryption on my home WAP but no luck. I tried browsing by IP address instead of website name, but nothing. Interestingly, when I connect to a public wifi hotspot it works fine!

Based on all that I assume this is an issue between my phone and my wireless router. Unfortunately I have the latest router firmware and can't upgrade it. Guess I can buy another router. But it's hard to believe that a router issue would be so specific that it allows Google-based items to work but no others. If my other wireless devices have no problems would OpenDNS make a difference?

Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.