• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Widget installation problem!

marco772

Member
May 15, 2011
52
0
Hi,

I have a rooted San Francisco/Blade, updated to 2.2 but I've noticed a problem with widgets of late.

When I reboot my phone my active widgets vanish! In their place on screen is a white square with "Problem loading Widget" written in it.
When I go into the widget list it will be missing although it shows up in my applications drawer.

I've done quite a bit of fiddling with the phone and have a few apps that move things to the SD card (Apps2SD and Move2SD Enabler) and imagine it's something to do with these.

I uninstalled my vanished clock widget and then reinstalled it but it installs directly to the card. Even if I use Apps2SD to "Move to phone" it seems to make no difference!

What I can't figure out is how to download my apps directly to the phone and then move them to the SD card only if I say so.

I had a few other apps I downloaded whilst trying to optimize the internal memory but I'm starting to forget what they all do/have done now!

Is there some magic button I can press which will keep my downloaded widgets in the phone memory rather than putting them onto the card?

Thanks for reading

Mark
 
Ahh, I think it was because I was using Move2SD Enabler and had it set to external. I changed that to internal and it seems fine now. Shame it can't be set to exclude widgets and stick everything else on the card.
I found even if I then did a 'Move to phone' on the Widget then it wouldn't work.

So sorted. I think. :)
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones