• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help WiFi problems


Aug 8, 2012
I've had a good search on the forums and Google but can't seem to find an answer to my problem.

I have only just recently added ICS to my Touchpad and I'm quite pleased with it. However, whenever it's used to access the Internet eventually the signal will disconnect at the computer and I have to reboot the router and broadband box.

I used all the recent programs for installation and the nightly update from August 3.

It varies as to how long it takes, seconds to half an hour sometimes. This is driving my wife mad and means an awful lot of rebooting. I can't recall that this happened with WebOS, so it must be something to do with ICS (the laptop and Sky box also work fine).

Has anybody come across this problem? Would it be worth making changes to the router settings? I use Windows 7, a Virgin broadband box and a Netgear WGT624 router.

Many thanks.
Frustrating... my TouchPad would prefer channels 1-6, and the other devices (laptops and iPads) seem to prefer the higher channels. Wifi Analyzer recommends channels 12-14 (I suspect based on the least amount of usage in my area) and my router (Cisco Valet Plus) only goes to channel 11.

So to keep peace in the house... I am using channel 9. May try to move the modem and router or eventually look at an extender.
Upvote 0

Thanks again... wow, that is quite the laundrey list. I am curious about the last one since it would appear to accomplish #2 (the most involved of the fixes). Fixes 3,4,5 are basically checked since the Cisco router is already set at "WPA2/WPA Personal Mixed Mode" (there isn't anything else that appeasr to come close to "PSK TKIP + WES"). I don't think its dual band and I think its B/G only too (I will verify both of those). I already use Wifi Analyzer. I haven't tried the clock fix (will do that), and when I tried the airplane mode suggestion it not only didn't improve anything it seemed to knock out my Apex launcher (I rebooted and restored that, and turned off airplane mode).

I am hoping FXR Wifi Fixer and Rescue doesn't cause more of a problem that it fixes.

Ultimately I think I need to move the router to a central location (its currently in my office) and/or get an extender.

Again, thanks for the help and advice!
Upvote 0
Tried FXR Wi-Fi Fixer. No improvement. I went back to webOS and immediately the Wifi improved (even though the webOS only has a three segment meter it was clearly a stronger signal at the extremes of my house where the CM9 TP loses connection.

Also found I can't move the modem since it needs access to a phone jack. So my only fix appears to be an extender.
Upvote 0
Try this:

Create a backup in recovery and TIBU, then do a factory reset and flash a known good rom. See if the problem is resolved. Don't restore any system apps or settings (red or green) from TIBU like wifi. If it's not any better, restore your backup.

My TP is a stubborn booger it appears. Went to recovery (in my case, that's TWRP), wiped and then factory reset, then reflashed the 7/11 zip I had from the past (seemed to me that one didn't suffer...). Wiped again, then rebooted.

I had to reenter lots of early stuff (gmail account info, find and connect to network, etc) which gave me hope.

Seems to be stronger when I sit next to the modem and router in my office, but still gets weak as I go to the rooms at the extremes of my house (again, the webOS signal appears to be stronger at these extremes).
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.