• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root About to smash Ally into a wall... market errors!!


Apr 11, 2012
Hello, I am going #@%^& crazy with my trusty LG Ally. First some background:

(I am plenty frustrated so I apologize in advance for typos.)

My Ally is nothing special, just an average Gingerbreak-rooted phone.

2 nights ago I downloaded MLB At Bat and had a blast with it. Then I noticed it was eating a lot of memory so I figured I should remove some junk I don't need anymore to free up space. This is apparently where the trouble started.

The phone was fine when I turned it off and went to bed but when I woke up it said some of my programs were in copyright violation. (!!) So I went to go to Market and I got that infernal process.com.vending error. Like a dumb***, I factory reset the phone. When the phone finished booting up, there was zero Market on it. Furthermore, all attempts to find and upload a market.apk file are problematic. Sometimes the Market screen comes up, sometimes not. But EVERY single frakin time I press My Apps I get the process.vending errror and a forceclose.

I have tried installing vending.apk, using a different marke (Appbrain). Installing GooglePlay, and all meet with the same error.

My phone is the only "computer" I have and it is out of warranty. I cannot afford a new one and I'm not due for an upgrade until December. Before this I had a Treo because of a deep distrust of Windows. The old Treo is still around here somewhere, I hope I don't have to go back to it!

Please, I have read many of the posts here -- you all are brilliant at this stuff and Ally is an old phone...I can't help but think at least someone on this site knows what will fix this cursed thing. I've searched all over this forum and others but all I find is that if clearing cache, or data, or factory reset don't work then I am screwed. I can't believe it, there has to be another way....

Thank you in advance, everyone and anyone who reads this.
I'm no expect at this by all means, but do you have access to recovery? Maybe try installing a rom on like

Velocity 1.2

StormDroid 2.0

Just an option to throw out there.
  • Like
Reactions: nybbler
Upvote 0
Thank you so much for replying, I am very grateful! :). Now I show just what a n00b I am...what is "recovery" and how do I get there? I tried to find it before on my phone but failed. And also what is a ROM? Will I need to use my spouse's Winblows lapto or is this something I could do all on my Ally?
Thanks again!
Upvote 0
Welcome to the world of pushing your phone to its limits.

One ROM that Jaison didn't mention was Bionx, though don't expect too much support since the dev stopped working with the Ally. . .

As for your questions. . .

Recovery is basically a menu from which you can do many functions in the phone, such as installing custom-built themes (as in modified frameworks, not icon themes for launchers), flashing ROMs, and wiping memory. Two well-known ones are the ClockworkMod Recovery and the getitnowmarketing Amon-Ra -style recovery. CWM can be flashed with an app called ROM Manager, while the AMon-a -style recovery has to be flashed in Terminal.

This thread can help you with getting one for the Ally. http://androidforums.com/getitnowmarketing/330813-all-one-recovery-thread.html

A ROM, by my understanding, is basically the Android system. Stock ROMs are the ones that come ou-of-the-box with the phone. Custom ROMs, like the ones jaison and I mentioned, are modified versions of the Android system that contain tweaks for better performance, a fresh new look, or just as a cleaner version of the system (in the case of bare ROMs with nothing added but system tweaks).

However, in the case of your app market not working, it seemed like a permissions issue. Try to find a way to get ROM Manager on your phone, and use the Fix Permissions feature to repair your apps. It could also have been a system issue, which we don't really know how to fix unless it's caused by something specific in the system. In that case, just flash a recovery through Windows and and then flash a custom ROM like jaison said.
  • Like
Reactions: nybbler
Upvote 0
Thank you for all your help (both of you!). I downloaded ROM Manager and attempted to Fix Permissions. I came up with an error message. Then I tried flashing CWM and that failed. Argh!! I did go ahead and get a full download of StormDroid, it is zipped on my SD card.

For some reason my Ally does not allow me into Recovery, I see the <!> for just 1 second before it pulls up Verizon's screen.

Thanks again!
Upvote 0
For some reason my Ally does not allow me into Recovery, I see the <!> for just 1 second before it pulls up Verizon's screen.
Flash the getitnowmarketing version of the amon ra recovery. There are many links around here. Ill post them when I have time

Follow these steps for the recovery:

I think the recovery.img is in one of these two zip files after you extract them I think:

List of 2.2.2 ROMs:

Velocity 1.2.2 Beta

Multiple versions of Bionx:

Velocity 1.2.1 and Patch

Stormdroid 2.0

Stormdroid 1.2.1 and Patch
Upvote 0
Thanks! I am not sure what adb is, so I looked it up. I managed to download a copy, but now I see that I also have to have Sdk, which I tried to find. Each attempt at downloading SDK has failed (I tried 5 of them, incl Android developers' link). My desktop is Ubuntu without an internet connexion, so I have to download everything thru my Ally and then the PC takes it off the SD card. Oh and also, does Eclipse figure into this at all? Somewhere I saw that I have to get that too.

This is making my head spin! I sure hope I'm not going to have to get involved in Linux source code..that always ends badly. I don't know squat about source code and I'm barely literate at far as using commands with the Linux terminal.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.