• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Android tablet - cast only worked once


Thread starter
Jul 23, 2023
I have recently replaced my tablet. The new one is operating on Android 13. I tried to cast to the family room Roku tv. I tapped cast, it found the tv, I tapped on it, it connected, showed the "allow" screen on the tv, clicked allow and it cast. This is just how my old tablet worked. I disconnected like normal. A while later I tried again. It will not cast anymore. It does not find the tv unless I tap the setting icon on the cast window. This opens the full setting screen. After a couple seconds it locates the tv. I tap on the tv and it shows it is connecting. After 5 or 6 seconds, the tv disappears from the screen for a few seconds then reappears as available. It will not connect. I tried the upstairs tv and had the exact same result. It worked one time. All units are on the same wifi. I have restarted, unplugged, reset everything with no luck. I have searched the internet with no luck. I would appreciate any help you can give!
maybe this?
I checked it out and tried what they said. My setting do not include the items they said to use except for "cast" which isn't working. This wouldn't be so frustrating if it never worked, but it did once. That's what I don't understand. I have downloaded many apps that just open up cast. I can do that myself lol. I found one app that mirrors the screen, but no sound, and there is an add every couple minutes.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.