• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Android TV Box Wont play video in Web Browers or BitChute

Box Info - 128GB HK1 Box Amlogic S905X3 128GB Android 9 4K 1.9GHz TV Box


I get the following error message when trying to play video on a website using the Firefox, Chrome & Parrot browsers.

"The media playback was aborted due to a corruption problem or because the media used features your browser did not support"


Bitchute will also not play, it looks like the video is stuck trying to buffer, though the same video will play on a laptop with no issues.

I installed Bitslide though this also does not work.

Any one else had these issues and know how to resolve this problem?
 
If I'd wanted to know about Chromecast I'd have asked
i understand. i'm just saying we get soooooo many people with issues with these off brand, never heard before android boxes. and all of them seem to have some issue or another. chromecast is so simple to use and can be so versatile. my friend uses it mainly as a computer. he uses his tablet to mirror to his tv. he has a bluetooth keyboard connected to his tablet and he can use microsoft office to do his work projects from. he can cast his videos. he can then take his chromecast to work, connecct to his work wifi and then use the chromecast hooked to a projector and can then cast his powerpoints and videos really easily.

it is something you might want to think about.

does your box work with mp4 files? can you just download the video and play it that way rather then go thru the browser?
 
Upvote 0
Thanks for the reply ocnbrze.

A little background info, the TV Box is my elderly mothers and Youtube banned a News Channel she liked to watch, hence trying to watch the video direct at their website or Bitchute / Bitslide.

I had previously suggested using a "Cast" app but her eye's glazed over as I explained :-(

I'll keep looking for a solution and if I find one I'll update the thread :)
 
  • Like
Reactions: ocnbrze
Upvote 0
Sounds like it's an issue with the webview firmware in the device. And a fix for that would need to come from the box's manufacturer via an update. What Android version is the box actually using?

FWIW I use a T95 Android 10 TV box, and that plays videos from Bitchute and other sites no problems with a browser.
 
Last edited:
  • Like
Reactions: Dannydet
Upvote 0
Sounds like it's an issue with the webview firmware in the device. And a fix for that would need to come from the box's manufacturer via an update. What Android version is the box actually using?

FWIW I use a T95 Android 10 TV box, and that plays videos from Bitchute and other sites no problems with a browser.

It's Android 9 Mike DT

Here's a pic of other info about our TV Box
 

Attachments

  • aNDRoiD BoX NFo_resize.jpg
    aNDRoiD BoX NFo_resize.jpg
    87.7 KB · Views: 395
Upvote 0
It's Android 9 Mike DT

Here's a pic of other info about our TV Box

Android Security patch, August 2018

So apparently the box's manufacturer isn't bothering to update and support their product. As it likely is a firmware bug causing the video problem. Quite frankly I don't think you can do anything with it, apart from replacing the box with another device that works.
 
  • Like
Reactions: Dannydet
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones