• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Another CM10 bootloop

With HTC not supporting the One S anymore I decided it was time to get the stock experience and try out Cyanogenmod 10. I thought I had it figured out but now the phone is in a bootloop. My phone is an HTC One S with the S4 processor and my carrier is Telus. Here's what I've done so far:

-Bootloader unlocked using HTC dev unlock
-Using Philz Touch 5 recovery (CWM base version 6.0.3.2, build 5.07.1 0 HTC One S) and rooted using Hasoon2000's toolkit for HTC One S
-Flashed Cyanogenmod 10 stable build from sdcard

Once I was done that I rebooted and it's been stuck in a bootloop ever since. It gets to the Cyanogenmod logo and sits there. Now that's I've done more reading about it, I realize that I did a couple things wrong:
-I didn't flash the kernel, which apparently you have to do when you use HTC dev unlock. I pushed the boot.img file to the phone using this post as a guide, but now I'm finding I can't even reflash CM10 - it can't mount the sd card.
-While my apps and settings are backed up using Helium, I didn't back it up in the recovery. I know, rookie mistake.
-I also don't have the Google apps, but that seems like something I can sort out later.

I considered bringing it back to stock but I can't find a One S RUU for Telus and I don't know if one exists that's downloadable.

If anyone has any ideas I'd really appreciate it. It seems like there are a few possible solutions but I can't get any of them to work. I've been at this all afternoon.
 
typically bootloops are encountered on an s-on device when one flashes a rom that requires a different kernel,and then fail to successfully flash that kernel.

flashing the boot image should have got you up and running,even without reflashing the rom,as long as you used a rom for one s,and the boot image that comes with it.

failing that,you can try what this user did to get his internal storage working again: http://androidforums.com/one-s-all-...ount-sd-card-no-rom-only-access-recovery.html
 
Upvote 0
Actually I managed to get it working just after I posted that. I pushed the boot.img file to the phone using Flashboot and after that it booted normally. I also clicked on the link you posted where the guy had the same problem with the SD card not mounting. I did what he did and it worked perfectly - surprisingly simple actually. I copied the Google apps zip this time and installed them through the recovery. Now all that's left to do is install Helium and get back all my apps and settings. Thanks for your help, that one link alone solved a lot of headache.
 
  • Like
Reactions: scotty85
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones