• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Asus Nexus 7 - "Google play has stopped" :(


Jan 5, 2014
Hey guys :)

I just picked up a cheap Nexus 7 (model ME370T). I know it's an old device but I bought it for the sole purpose of running just one app - Torque Pro.

However, every time I try searching in Google Play I'm able to type a few letters before it says "Unfortunately, Google Play has stopped" :(

I've done a factory reset, I've tried clearing app cache/data, it wouldn't appear there aren't any updated available... Not sure what else to try :/

Any suggestions?

Your running a very old version of Android.
And you're overall specs for memory is low.
Have you tried just rebooting it?
Or doing a factory reset?

Thanks for your reply... I think I have actually fixed it now with a few app updates. Couldn't find app updates at first as they're not in the usual place because of the old OS!

I know specs are low but it should be fine for just running the one app that I need it for. Thanks for you help anyway!
  • Like
Reactions: Dannydet
Upvote 0
The Torque Pro app is apparently a pay-for app so perhaps it needs to be installed and sourced via Google's Play Store oversight because of some contractual issues that Google enforces.
An alternative from the same developer is a free version, Torque Lite, available on the APKmirror site. Read through its Description section if the Lite version's reduced feature set will work out for your needs.
  • Like
Reactions: Dannydet
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.