• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root At my wits end :( Please Please Help

Hello fellow knowledge seekers. Lovely Forum you have :)

I am at my wits end as the thread title says i really am, its giving me a headache now. Ive been going round in circles for 4 days now reading every scrap of info,guides,posts etc and downloading and trying everything to get my phone to work again. I feel like a fool for messing with it in the first place (wanting to learn).

Ok what i done (everything i can remember) & Symptoms of device

HTC One M8 Vodafone UK

1. Used the One_M8_All-In-One_Kit_v2.0
2. Went through all the process of getting token, flashing twrp and installing supersu and updated the binaries.
3. All went great! was rooted and working 100% until....

4. So i was messing with an app which wouldnt work due to permissions although it had root permission.

5. So i was messing around some time later in twrp recovery and noticed permissions (i thought about the app and decided to "fix permissions" :( big mistake as they are nothing to do with app permissions as i later learned.

6. The device booted fine into the OS but all my installed apps where missing and some other standard android apps that come with the phone were missing but other than that worked.

7. Decided to go back into twrp and look around. I decided to install supersu again to see if it would fix the permissions :( nope it made it worse. It then presented me with the htc white screen with green htc logo and stayed there.

8. Used key combo to get back into twrp, done factory reset, nothing.

9. flashed everything i could find including ruu exe's and zips. (errors upod installation) nothing worked :(

10, when i exit twrp it says no os installed and then your device doesnt appear to be rooted install super su? slide to install. installs fine then next time i exit it does the same.

I have adb, fastboot and access to phone via pc.
The phone loads in windows and i can access internal storage and sd card.
All my files and data are still in internal storage.

Any advise appreciated.

Phone info.

Team Win Recovery Project v2.8.5.2

eMMC-boot 2048MB
Aug 4 2015,21:56:12.0

C:\adb>fastboot getvar all
< waiting for device >
(bootloader) version: 0.5
(bootloader) version-bootloader:
(bootloader) version-baseband: 1.25.214500021.06G
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main:
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: ***************
(bootloader) imei: ******************
(bootloader) imei2: Not Support
(bootloader) meid: 00000000000000
(bootloader) product: m8_ul
(bootloader) platform: hTCBmsm8974
(bootloader) modelid: 0P6B10000
(bootloader) cidnum: VODAP001
(bootloader) battery-status: good
(bootloader) battery-voltage: 0mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: 255f41e7
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0

Any other info required i will do my best.

Thank you
Last edited:
Thank you for your reply :)

No backup like a pro noob :(

I dont know the version of the os if thats what your asking? Its blank on the getvar list.

TBH I have no idea what numbers are relevant except radio, platform? and cidnum. I tried to match as many numbers as possible in my searches.

I think the root is messed up and supersu installs and the binaries install but when i reboot and exit it says im not rooted swipe to install, appears to install fine but doesnt actually root.

I tried this one as it seemed the closest in bootloader screen and throws *unknown error 155*


I have a link here Ref.* that provides a backup nandroid of the VODAP001.. but im afraid incase i brick it completely so i decided it would be a good idea to register here and ask :)
Nandroid Backup CID VODAP001 thanks to alextheg

Nandroid Backup CID VODAP001 thanks to alextheg

Any advise appreciated, system got wiped aswell as all relevant caches between and after flash attempts.

Thank you

Edit **
Last edited:
Upvote 0
Version according to exported recovery.log of backup or whats left after titsup indicates...

Is nandroid backups exclusively for the clockwork mod?

Im trying to piece this altogether in my head its bloody hard, help appreciated :)

Edit* Also where i would find the firmware version number please? < Total noob i know :)

Thank you
Upvote 0
Hi for anyone reading that is stuck like me.

If youve got this far you know how to use adb, flash twrp etc.. Onwards.

Device Info.
Vodafone UK
modelid: 0P6B10000
no os installed (blank version after brick)

You will need a Computer, im using win8.1 pro x64 atm.

This will wipe all your data.

TWRP Latest Version.



1. - flash latest twrp via fastboot.

2. - Create a backup with TWRP of what you can.
- It will create a backup of what youve got under the twrp/backups folder with your device serial number as the folder name.

3. - Download M8_UL_TWRP_Nandroid_4.19.161.2.zip

4. - Boot your device into twrp recovery.

5. - Connect the device to pc. It should let you access the storage with the new twrp.

6. - Copy the folder in twrp/backups/yourserialno on your device to your pc.

7. - Delete the files in the twrp/backups/yourserialno folder twrp just created on the device.

8. - Extract M8_UL_TWRP_Nandroid_4.19.161.2.zip and copy the files inside into the twrp/backups/yourserialno folder.

9. - In twrp, Select wipe and slide to factory reset.

10. - Go to Restore in twrp and select the backup.

10. - Follow prompts, after install & reboot it will show the vodafone screen "if applicable" then the white htc logo screen and stay there for a while, just leave it alone then it will start updating android apps etc.. and present you with the device setup.

I have included the link to the firmware too if you need it. I didnt need it in my case.

Alternative and much simpler.

Viper M8 ROM - Currently running on my m8. :)


All carriers supported including vodafone uk

Just copy onto device, boot into twrp go to install and select the ViperOneM8_4.3.0.zip follow the Aroma installer prompts, good to go!

Hope it helps someone

Last edited:
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.