• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Attachments


Nov 13, 2009
I'm having major issues with attachments in my pop3 e-mail, as I think other are having. Any help would be appreciated.
(I am updated to 2.0.1)
(incoming pop3 is pop-server.roadrunner.com, security is none)
(I have documents to go)
(rest of e-mail works fine)

1. I can view a few attachments, occasionally some pdf's and wmv's, but most pdf's and doc's say "fetching attachment" followed by "this attachment cannot be displayed." It is extremely infuriating as I need to see these files on my phone. They open perfectly on the pc.

2. I see no way to save these attachments. Menu or long press does not give a save option.

I'd appreciate any and all help.
The problem is not with the reader, it's with attachment handling. I tried this experiment with some interesting findings:

I was sent a simple one-page PDF page from my insurance agent. When I tried to open it in the e-mail, I got that "fetching" and then "this attachment cannot be displayed message."

I tried forwarding that exact e-mail back to myself from my pc. Again, I got the same errors on the droid.

I then, on my pc, copied the pdf file to my desktop and inserted it (same name) into a new email and sent it back to myself. That PDF opened perfectly on the droid.

I just had the same problem with and got the same experiment results with a JPG file.


Additional info:

I just installed K-9 mail and tried that. Interesting that I got almost the same results. When I tried to open the pdf or jpg from the originally sent e-mail, I got a K-9 message "unable to find viewer for application/octet stream." When I went to the same file from the e-mail which I saved the file on my pc, then re-sent it back to myself to open on the droid, it opened fine. I didn't change the name of the e-mails or anything.

Upvote 0
Comment 5 by scottstan, NI read this on another forum (Issue 4565 - android - unable to open attachments to emails from Exchange Server. Get perpetual "fetching" - Project Hosting on Google Code Nov 08, 2009 I may have found a fix for this issue. By un-checking "accept all ssl certificates" under
incoming server settings. I can't guarantee this will work for you, but it worked for me
without any undesirable side effects that I have found. Hope this helps.

However cant figure out where to change this setting? If anyone knows please update us
Upvote 0
Precursor- I am a layman and therefore this will be basic and as I understand it.

I am new to Android OS from Blackberry and so I am working on trying to figure everything out. I am having the problem of opening some .pdf files. I don't know yet if the problem exists with other file formats. I have an automatically generated pdf report emailed to me. I cannot open it directly from email on Android but I can on the PC. I can save it to Android and open it from there. I can save it to PC and re-email it to myself and open it. Through Android email app, it says "cannot be viewed". Through K-9 email it says "Unable to find viewer for application-octet/stream"

This seems to only happen with some (not 100% sure if all) automatically generated named pdf files. According to my IT guy, the octet/stream is something to do with the binary encoding. This means nothing to me and it the main reason that I voice a concern is that by saving the file locally in order to view it, it is more time and memory consuming than it theoretically should be (and was via the blackberry).

FYI- I began using the default Android email. Tried K-9. Downloaded Adobe Reader. Other non-auto. gen. pdfs appear to work fine.

I hope this helps someone more knowledgeable than me to come up with a solution.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.