• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Cannot Connect To Camera

Just recently, I have been trying to use my camera in vain. Every time I try to access it, either by the camera itself or through an app such as Layar or Barcode Scanner, I'm met with an error, basically saying that I'm unable to connect to the camera. If anyone has any suggestions other than resetting to stock v6, let me know. If I don't get any good ones in about 8 hours, I will be resetting. I'm on velocity 1.0, by the way.
Like a logcat? Otherwise, I don't know what kind of error code. I'm at work right now, otherwise I'd hook up to a computer to do a logcat.

Edit: After running a logcat, the only thing that jumped out at me is:

E/QualcommCameraHardware( 1282): startCamera X: /dev/msm_camera/control0 open failed: Unknown error: 0!
E/QualcommCameraHardware( 1282): createInstance: startCamera failed!
D/AMCE ( 4261): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
D/AMCE ( 4261): Fail to connect to camera service
D/AMCE ( 4261): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I'm not sure if this tells you anything or not, but I'm pretty sure I'm gonna do a full restore.

Edit 2: I just did a full restore to zv6 and then went through upgrades, camera still doesn't work. I guess it's time for a new phone.
Upvote 0
Well, just got off the phone with Verizon and they are sending me a replacement phone. Sorry to clutter the forum with this thread, but I didn't see this problem addressed anywhere else.

The steps I took include going back completely stock, doing a factory data reset, reflashing Velocity 1.0, reinstalling the ArcCamera app, and restoring a nandroid from when my camera still worked. Not in that order. All that, but to no avail.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.