• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Cannot unlock bootloader on Samsung Galaxy A10e. Fastboot < waiting for any device >


Sep 11, 2013
I am trying to unlock the bootloader on my Samsung Galaxy A10e.

Go to "Settings" -> "About Phone" -> "Software Information" -> tap on "Build Number" 7 times

This enables "Developer Mode". Then I go to

"Developer Options" -> Enable "USB Debugging"

According to the instructions on the above website there should be a "OEM Unlock" option under "Developer Options". But there is not.

Method 2 explains:

In case there is no "OEM Unlock" option then:

Install ADB and Fastboot tool:

I used

# sudo add-apt-repository ppa:phablet-team/tools && sudo apt-get update
# sudo apt-get install android-tools-adb android-tools-fastboot

Then per instructions:

# adb devices
List of devices attached
RF8N217Q6WB device
# fastboot devices
# fastboot oem unlock (or sudo fastboot oem unlock)
< waiting for any device >

And it does nothing.

Then I tried

# adb reboot bootloader
# fastboot device (or sudo fastboot device)
< waiting for any device >

And it does nothing.

I also tried:

# adb reboot bootloader
# sudo fastboot oem unlock
< waiting for any device >
And it does nothing.


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.