• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Can't flash stock rom or stock pit in Odin


Well-Known Member
Jan 17, 2011
Hello all...i've tried everything to try to bring my old S2 I727 back from the half-dead but just can't figure it out. Quick backstory. GF's kid wanted a phone so we gave him an old S2 I727 with CM10 (or 9 can't remember) on it for service with Cricket. One day the phone just quit on him and it wouldn't boot up. Had Clockwork recovery on it. Now this was a few months ago and I forgot exactly what I did to try to fix it but I got it working but then tried to flash something else and screwed it all up and now it only boots to the Samsung logo. Since i fudged with recovery I can't even boot into recovery now. All i can do is boot into download mode. At the top it says
Product Name: SGH-I727
Custom Binary Download: No
Current Binary: Samsung Official

Now here's where the problem is.

First I tried the emergency firmware recovery with Kies but it wont connect to the phone at all. I have the drivers installed. Since that didn't work I uninstalled Kies.

I tried to flash a couple of stock ATT roms to it using Odin 1.85, one of them being SGH-I727-UCKJ2-k0nane. When i do this I get the error:

<ID:0/004> Odin v.3 engine (ID:4)..
<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> There is no PIT partition.
<ID:0/004> Added!!
<OSM> All threads completed. (succeed 0 / failed 1

So I found a celox pit for the Skyrocket but when I try to flash just that I get:

<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Complete(Write) operation failed.
<ID:0/003> Added!!
<OSM> All threads completed. (succeed 0 / failed 1

I've tried different cables, USB ports and computers. It's like there's no way to fix this thing. I can't flash a rom because it's telling me there's no PIT partition...i can't flash a PIT because I just keep getting Complete Write Operation Failed. I don't even need to use this old phone but the OCD in me wants it working. I'm about to give up unless anyone has some suggestions for me.

Last edited:


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.