• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Can't select in My Files to upload file


Oct 27, 2014

I have a really simple problem. I have a new galaxy tab pro. If I use My Files, I can select files with no problems, or multi select them. Each file has a little square box at the corner of the icon which shows a selected tick.

Now, if I try and upload a file to a website (through any browser - chrome or android browser) the My Files window comes up, but I can't select any files. Each icon has a circle rather than a square, and they just don't select. I've tried pressing all over, and tried a long press. The long press just opens the file, but I still can't select anything, so I can't upload any files.

Any ideas? It must be something embarrassingly simple?

many thanks
This is actually my mother's tablet. I've now installed a different file browser, but in the meantime she has managed to set up the tablet (somehow) so that clicking on 'add photos' in ebay goes straight to the camera to take a photo, so I don't even get a choice about a file browser.

I can't see how she's done that, and of course she has no idea what she did. It seems to have been done in tablet config somewhere, since it also happens for other browsers (funnily enough gumtree gives me a choice, but doesn't list the new file browser, so that's not too handy either)

Any ideas gratefully received.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.