• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Cant turn off vibration for notifications 4.2.2

poccari

Lurker
Jul 21, 2013
7
0
Hi,

I've tried searching but haven't found anyone else with this problem, so thought that someone has a solution here.
I have recently updated at 4.2.2, and found that my phone vibrates with every notification I receive. I'm happy for my phone to vibrate when it calls or I receive a SMS, MMS etc, but I dont want it to vibrate when I receive an email, or facebook notification etc.

Before, I just unchecked the "vibrate" setting in each app settings (gmail and facebook), but it still vibrates when a notification comes in even if it's set not to vibrate for this application.

As I receive a lot of emails, it's driving me up the wall. I've tried everything, factory reset, flashed a stock XZ ROM of 4.2.2. and it still happens!

Is there some setting that I'm overlooking, or is there an app which can fix this?

Thanks in advance for any assistance or light you can shed on this matter!
 
Go to settings sounds and there should be a box to uncheck about vibration.

Good luck.

Thanks for your input. But I dont want to turn off all vibration (i.e. I still want it to vibrate to get phonecalls and SMS), but application specific notifications like facebook and gmail. Each app has it's own setting to have vibration or not, which in the past has worked fine. I've checked and the settings in the gmail and facebook app definitely have the vibration setting set to off. But whenever I get a notification from these apps, it vibrates.

My phone has a setting in where you say, but it says "Vibrate when ringing". I may try this and see how it goes. Thanks!
 
Upvote 0
Just a thought.... do you have FB etc accounts linked to Socialife? If so, it might be the source of the mysterious notifications. Go into Settings/Apps, select Socialife and disable "Show notifications".

Cheers Slug.... no, that didn't do it (I hadn't registered any accounts with Sociallife, but I froze the app just in case). Still vibrates whenever I get a gmail or FB notification. Just confirming, are you running 4.2.2? Are you having the same problem?
 
Upvote 0
Twitter’s settings interface actually offers many more configuration options than are obvious at first glance.

At the top, however, there’s a section headed Accounts, the first entry under which should be your account name. Though there’s nothing to indicate it, clicking on this takes you to another menu offering many more settings – including a whole section headed NOTIFICATION SETTINGS.

Read more: Twitter for Android: how to stop unwanted alerts | PC Pro blog Twitter for Android: how to stop unwanted alerts | PC Pro blog



گردا
 
Upvote 0
Hi,

I've tried searching but haven't found anyone else with this problem, so thought that someone has a solution here.
I have recently updated at 4.2.2, and found that my phone vibrates with every notification I receive. I'm happy for my phone to vibrate when it calls or I receive a SMS, MMS etc, but I dont want it to vibrate when I receive an email, or facebook notification etc.

Before, I just unchecked the "vibrate" setting in each app settings (gmail and facebook), but it still vibrates when a notification comes in even if it's set not to vibrate for this application.

As I receive a lot of emails, it's driving me up the wall. I've tried everything, factory reset, flashed a stock XZ ROM of 4.2.2. and it still happens!

Is there some setting that I'm overlooking, or is there an app which can fix this?

Thanks in advance for any assistance or light you can shed on this matter!
To turn off vibrations tap the message icon on your screen. At the bottom of your phone tap the menu button its on the left. Scroll down to notifications setting and select vibrate, u mark or unmark.
 

Attachments

  • Screenshot_2015-08-12-23-37-13.png
    Screenshot_2015-08-12-23-37-13.png
    93.6 KB · Views: 913
Upvote 0
Hi, the below information may help you...

I went into the app (for me, this was maildroid), accessed the menu within the app, where there is a 'Notification Channels' option, when opening this, there is then a list of options that are checked or unchecked - one of these is 'vibrate', I unchecked this & that fixed it for me - no more vibration on notifications from maildroid.

Prior to this, I had already unchecked the vibrate under sounds settings in the general phone settings, which didn't stop the vibrations on these notifications.
I had also gone into the settings for maildroid & could not find anywhere that it referred to 'vibrate'. Also could not find reference to 'vibrate' within the 'notifications' area within the settings menu for maildroid. And could not find anything relating to 'vibrate' within the notifications area within the phone's general settings.

Hopefully the app you are dealing with has 'notification channels' options/settings somewhere.
 
Upvote 0
To turn off vibrations tap the message icon on your screen. At the bottom of your phone tap the menu button its on the left. Scroll down to notifications setting and select vibrate, u mark or unmark.

Thank you Honeytea for this info. I finally found where to turn off vibrate on notifications (for my text messages). I have a droid 4 xt894. After I tapped message icon and then pressed menu and settings i found the vibrate on/off in the delivery reports of all places. They sure put stuff in obscure places on this phone.
 
Last edited by a moderator:
Upvote 0
I found this worked for me:

https://support.google.com/nexus/answer/2819577?hl=en

For the lazy:
"When your device's ring volume is turned all the way down to vibrate mode
_hnFp2yw-RMC6N5aAejURTRoSOFjOAuWfAbyMltJC-R9esfYiDZwK-z2OMgYU2i1TJMqUQ8ixw=w24
, notifications that are set to play a sound will vibrate instead. Notifications set to vibrate will still vibrate."

I.e. turn of vibrate for notifications on a per-app basis. If you have your phone on vibrate mode, it will vibrate for notifications with sounds instead of playing the sound.
 
Upvote 0
Hi,

I've tried searching but haven't found anyone else with this problem, so thought that someone has a solution here.
I have recently updated at 4.2.2, and found that my phone vibrates with every notification I receive. I'm happy for my phone to vibrate when it calls or I receive a SMS, MMS etc, but I dont want it to vibrate when I receive an email, or facebook notification etc.

Before, I just unchecked the "vibrate" setting in each app settings (gmail and facebook), but it still vibrates when a notification comes in even if it's set not to vibrate for this application.

As I receive a lot of emails, it's driving me up the wall. I've tried everything, factory reset, flashed a stock XZ ROM of 4.2.2. and it still happens!

Is there some setting that I'm overlooking, or is there an app which can fix this?

Thanks in advance for any assistance or light you can shed on this matter!
There is no such option to uncheck the vibration alert for app notifications.
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones