• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Can't unroot


Apr 25, 2012
I'm trying to update my phone with the new update, but it keeps downloading, resetting to install, and turning back on and saying it failed to update. I figure it's because my phone is rooted (I think???). I used Super One Click to root, and have tried using it to unroot. It goes a long ways through, then says "Device does not have Superuser!" This happens every time. I try to update again and same thing as before. I even try rooting it again, and having it be successful, and updating and nothing. Root it successfully and try to unroot it again and same error about superuser.

Any ideas or ways to update without unrooting? FYI the only reason I rooted was to get rid of pre-installed junk apps. So now that those are gone, I don't really care about having it rooted anymore. I just want to update it, especially since it keeps automatically trying to update once a day.
You could always just disable the update feature. I went through the same thing for about a month which is why I rooted in the first place, then I got rid of all of the update features and then the preloaded apps.

I used AppQuarantine to disable the update feature. It'll at least hold you over until you find a way to unroot.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.