• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Completely Stuck in Android Upgrading loop

I was given an LG 7.0 tablet today, which I figured I could use at my live shows for credit card processing instead of handing ppl my phone.
I plugged it into the car charger & turned it on & set it in the passenger seat. I noticed it said something about Android, but was driving, so paid it no attention.
Got home & power was off. Ok, so car charger doesn't work. Plugged it in, turned it on & it showed 63%. Confused, but it's on. Did a factory reset. Deleted or disabled some ATT apps as I'm on Verizon & using this only on wifi. Turned mobile data off. Set up Google & Chrome, & let play store apps update. Restarted. So far, so good. Tried to download Square. Got a message it didn't install. Went to Play Store to try again, and instead of the "install" button, it had the "open" button, so I opened it. Slowwwww, but it loaded & opened. Closed it, closed Play. & grabbed icon from app page to put on the homepage, & tried to open....nothing. Deleted icon on home page, went to app page & it was gone, and also wasn't showing on settings/installed apps. It was still showing on the recent apps page though it wouldn't open again. Closed everything. Restarted. I then got the message as follows: Android is Upgrading... Optimizing app 1 of 1. This may take longer depending on apps. Please do not turn off the tablet until complete.

This is on a loop. It occasionally restarts itself and goes immediately back to this screen. I can not get into anything. I have tried the volume down/power suggestions, but it doesn't get far enough into boot to offer me the safe mode option. It just displays this. It's been hours.
Here's where I screwed up-
Everything I've read says it's a 3rd party app issue. Only d/l I did was Square. I looked up app specs and finally saw the issue....Square now requires Android 7 up. The LG is, according to the box, 5.02. It's never going to optimize 1) an app that's not there but probably listed in a cache somewhere, & 2 an app that won't work with this version.
So, without being able to use the power/volume down trick, nor get past the LG logo, what can I do? PLEASE someone take pity on me?

sorry but if you are in a bootloop, a third party app would not be the cause of it. this sounds more like one your system partitions got corrupted. and if you can't get the phone into either recovery or download mode, than this thing is toast.

(hopefully this is the correct tablet you have)
Last edited:
Upvote 0
You might trying returning to the play store and tap on the square app.
It will bring up the open option but might bring up the uninstall option as well. In the state your tablet is in it might not remove the app but it will cost nothing to try. I wish I had more to offer. I'm not knowledgeable of your tablet or a means to stop your loop. I'm surprised the app was available for a device that was incompatible.
  • Like
Reactions: ocnbrze
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.