• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Desire - root access stopped working

Hi folks,

I'm new here, I lurked for some time till something went wrong with my Desire :)

I rooted my Desire (Froyo, sw number 2.29.405.5) using unrevoked a month ago and everything was working fine. I backed up the original ROM from the Clockwork recovery, played around with CyanogenMon 6.1 and then went back to the original ROM.
I backed up my apps and data with MyBackup Root, restored them, everything was fine.

However, I tried the backup once again yesterday and MyBackup is asking for root privileges, I allow it (checked the "remember" checkbox) and then MyBackup asks AGAIN! Allow, asks again, allow asks again, etc. ad infinitum. The confirmation dialog is jumping up every 10 seconds until I force close MyBackup...
When I open the Superuser app, MyBackup Root is listed in the Allow list, along with Superuser app. When I select Settings tab in Superuser it asks for root privileges as well!
Then, in Superuser Settings, when I tap "Su binary v original" it asks for root again, finds new version of su binary. I confirm the update, receive "su binary updated successfully", but when I tap it again, it again find new version of su bianry and again "updates it successfully".

It seems to me the root access has been disabled somehow, but I'm not aware of any action that might have caused this. What I think might have some connection to this - I purchased Superuser Elite from Market to show my support. Could it have somehow broken the functionality of the original Superuser app?

I reinstalled all of these apps and wiped Dalvik cache but it didn't help.
Runing unrevoked again doesn't help either - "Error: failed to get root. Is your firmware too new", the Zysploit app remains installed...

I don't want to do full wipe/RUU untill I back up my data (games, mostly, which is not crucial, but I'd like to avoid playing all the Angry birds levels over again:)).

Any ideas?:)

Thanks for any help.
But we're you rooted at the time of the OTA?

No, unrooted till cca 8th of January. Then I did:

  • Backup of all the apps and data with MyBackup Root,
  • Nandroid backup,
  • full wipe,
  • flashed CyanogenMod 6.1.1,
  • restored the apps and data to CM,
  • backed up from CM,
  • returned to the rooted stock ROM,
  • restored apps from CM (worked fine)
And 3 weeks later Superuser seems to be broken. I still can boot in Clockwork recovery, though...
Upvote 0
Whenever I try to update the SU app I can't so I'm guessing the fact you can means the rooting isn't correct. I'd flash the ROM again and don't restore the app backups. Try an app that needs SU access and see if it works. If it does, it's the backup that's knocking it out

Currently I think the problem isn't the root access itself but how Superuser manages the permissions.
When I use Quick Boot (which requires su permissions) it asks for the permission and when I tap Allow it reboots the phone/whatever action I selected. However, even though the Allow permission is saved (visible in Superuser app in Allow list), QB asks again next time.
MyBackup Root seems to behave the same way - though it requires multiple (up to 50) Allow taps for backing up 1 app. When I'm patient and tap my way through the backup is finished successfully.
Haven't tried restore yet though... I may try that and see the result, if it works I can apply the original RUU and root again from scratch.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.