• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root DX (MB810) ezSBF & Root 2.3.4/4.5.621 (no milestone .sbf)


Android Expert
Jul 25, 2011
South Dakota
updated many times see change log

Root Only
[ROOT] Framaroot, a one-click .apk to root
I have verified it works with these Motorola devices running android 2.3.4
Droid 2 (a955), Droid 2 Global (a956), R2D2 (a957), & Droid X (MB810)

Just download, allow unknown sources, install, open, select top root method (Gimli), reboot phone, done

no pc needed.


Flash Original Stock Firmware with ezSBF

Steps 1 through 6 need to be followed exactly.
1. Download an .iso file (Droid_X_621-SBF-and-RootCD-2nd_edition.iso)
a. Verify the file was downloaded correct with MD5/SHA-1 Hash Checksums
2. How to use the .iso disc image file (use one of the options a-e)
a. burn to CD (Windows)
b. burn to CD (Mac)
c. mount to usb drive with unetbootin (Mac/Win/Linux)
d. Using Oracle VM VirtualBox
e. Burning .iso from Ubuntu
3. verify files created on CD/USB are correct
4. charge battery/ low Battery options
5. reboot pc from cd or usb
6. Follow onscreen instructions

ezSBF 2.3.4/4.5.621 & Magic MD5 Root
DX (MB810) ezSBF & Root 2.3.4/4.5.621 (no milestone .sbf) (213mb)

instructions and downloads posted DX (MB810) ezSBF & Root 2.3.4/4.5.621 (no milestone .sbf)- Google Docs

How to verify the file was downloaded correct with
MD5/SHA-1 Hash Checksums

what is ezSBF?
original [TOOL] ezSBF (not for 2.3.4)

Originally Posted by 1KDS
Don't let the word Linux scare you, this is just a cd you burn, nothing installs to your pc. Once you burn this CD you are ready to SBF flash anywhere you have a computer, no net connection needed to download any files.
This is an .iso file. It is a complete Linux operating system that you will download, burn to CD (or USB) then boot your pc from CD or USB, this allows your pc to reboot into a different operating system.

Originally Posted by 1KDS
Instructions (Mac):
Download .iso
Use Disk Utility (built in) to burn iso file to a CD (instructions)
Shut computer down
Hold c key, push power and hold c until you see the Linux OS start
Hit enter at the yellow "boot baby... boot" screen
You will see yellow dots for 3-5 minutes then the script will start

Instructions (Windows):
Download .iso
Burn iso image to a disk (Instructions, Windows 7 - Vista and XP)
Reboot PC
Hit F12 (sometimes F8 or esc) during boot to go to boot menu (possibly google search how to boot your specific pc from CDROM)
Select boot from CDROM (or USB if you used a flash drive)
Hit enter at the yellow "boot baby... boot" screen
You will see yellow dots for 3-5 minutes then the script will start

Live USB Instructions (Windows):
(Instructions from pendrivelinux.com)(thanks)
UNetBootin for Windows
Download your favorite Linux ISO
Double click the Unetbootin Executable to start the program
(1) Click the Diskimage radio box
(2) browse to select your ISO
(3) Set your target USB drive
(4) click OK to start the creation


(5) After the USB drive is done select reboot.
(6) During boot enter the boot menu and change USB to boot first, save and reboot.
(7) When booting from UNetbootin select SliTaz

Hit enter at the yellow "boot baby... boot" screen
You will see yellow dots for 3-5 minutes then the script will start



basically read onscreen directions

select DX
don't use numbers on right side of your keyboard, just use the ones above qwerty

turn phone on, connect to pc with usb cable

check usb debugging (settings/apps/development)
select charge only usb mode in top status bar

press continue
adb will push
data/local.prop /data/preinstall_md5/magic.md5
program will prompt you to
manually reboot phone to bootloader (Hold volume up+down buttons and power button, or hold Vol.Down and Camera and wait for the screen to flash)
program will will be flash repacked sbf (less than 50mb)
Program will reboot phone twice, very important (reboot just replaces the local.prop, but the old local.prop is still in memory, till second reboot)
adb pushes su,superuser, and busybox
program will reboot to recovery,
manually wipe cache (should auto reboot to recovery, at android andy press both volume buttons, if it doesn't press home button and hold it in then press your power button, hold it in also till you see a triangle on the screen w/ android andy then press both volume buttons)
then select reboot

error info
when running the program you may see these errors

rm failed for /data/preinstall_md5/magic.md5 no such file or directory
no root.img.gz no such file or directory
rm failed for /data/preinstall_md5/magic.md5 read only file system

that is fine, it will still work

after flashing files in bootloader, phone reboots to bootloader, instead of normal android operating system..... now what?try disconnecting usb, pull battery,wait a few secs, replace battery, reboot, wait for reboot to complete, reconnect usb

Using Oracle VM VirtualBox, and Magic MD5 root iso

If you planning on making nandroid backups or flashing roms
read [HOW TO] Install/Use Droid 2 Bootstrap

bhigham[/URL]/beh modified the root method
based on New D2 root method for stock 2.3.4 (621/622) found (Droid2, R2D2)

How this works
Originally Posted by phifc
There's an exploit in loadpreinstall.sh. It compares md5 sum files of preinstalled apps and if they're different, copies the md5 to the local cache. The preinstall just has an empty file in app/ so it will parse the md5 for it. Instead of an md5 sum, it contains a local.prop that allows adb root shell. So the system thinks it's copying the md5sum to the cache when it bounces off the symlink and overwrites the /data/local.prop, giving adb root on next reboot

originally posted by bhigham/beh
Since all these devices (Droid 2/R2D2/D2G/DX2 and DX seem to be vulnerable to the same exploit found by phifc at

I have assembled rooting methods for all of them in EzSbf style CD. I have tested it on my D2G, and the same method has been tested by multiple users on the D2/R2D2, and has worked fine.
Credit for this method go to phifc, djrbliss, and the others who developed the method.
I have simply taken the method, and assembled the tools.
Credit for the idea behind the CD method should go to 1KDS, as I have mostly patterned this CD after his method.
Credit should also go to Skrilax_CZ, as without his Motorola Android Firmware (De)packer, we wouldn't be able to have a 55 meg CD that covers multiple devices.
Special thanks also to themib for testing and troubleshooting on the DroidX2. In fact, since I don't have a DX2, he actually did a majority of the work in finding a method that would work (the method for the D2 and D2G doesn't quite work), and then we worked together to get it assembled and working.

old root
Magic MD5 Root Only
Droid2_D2G_DX_DX2-RootCD-2012.iso (54mb)
This CD is for the D2,R2D2, D2G, and DX on Android version 2.3.4, and the DX2 on 2.3.5.
One note if you have troubles with it not working. It might be necessary to disconnect the phone after it flashes the preinstall and reboots. It seems that some phones may not complete the reboot process before being rebooted by ADB, so you may need to disconnect the phone when it starts booting, and let it boot fully before hooking it back up. when hooked back up, it will be rebooted, and should go on with the process like normal.

Of course, like all other things here, I have done my best on this, but there are no guarantees, and anything you do on your phone is at your own risk.
So, without further ado, here is a link for the CD
and the md5 is

My Lists

Magic MD5 Root 2.3.4 for D2, R2D2, D2G, DX and 2.3.5 for DX2 - Google Docs

sd_shadow's [Collection] of Links: FAQs, Guides, Rooting, SBFs, ROMs... - Google Docs

13 sept 2012: added bootloader and recovery instructions
02 Oct 2012 added mac info
10 Oct 2012 added error info
18 Dec 2012 major rewrite
09 March 2013 added ezSBF link
26 April 2013 added Framaroot link
10 May 2014 reordered things
Wow, seems simple enough. Now I have a few questions (yes, I am new to rooting).
1. reboot phone to bootloader. Is this a menu option?
2. flash repacked sbf. Does this happen automatically? Is there a file name I need?
3. Reboot twice. How do I reboot? Do I turn the phone off/on or is there a special combination of buttons?
4. reboot to recovery and wipe cache are probably menu options.
5. reboot normally. How do I reboot normally?

Thanks for being patient.
Upvote 0
you need to reboot to bootloader manually
flashing will be done when you click continue
phone should reboot twice, just wait for it to completely boot before clicking continue, or it might skip one reboot
it should reboot to android recovery
at ! in triangle with android andy, press both volume buttons to enter recovery
choose wipe cache, comfirm
wait for it to finish
choose reboot in android recovery
Upvote 0
Wow, that was easy. Easier than SDB/SBF or whatever I've used in the past.
So, now that is done, what is different then factory image and root?
Do I now need to update or flash the latest OS? Use root keep and flash .621 again?
I'm on 4.5.621MB810
Droid X
Build 4.5.1_57_DX8-51
I think I have the latest everything, root, and antenna (15P) what ever that means.

I didn't loose a single app. That was a great tutorial!
Upvote 0
I did your rooting method and it worked awesome but I'm having trouble finding any custom rom's that will run with my rooted .621. If you have any clues that would be great. I already put bootstrap on and a freeze bloat, I've already shut off the nonsense verizon junk now I just want to really customize it.
Upvote 0
Upvote 0
When I click on the Droid2_D2G_DX_DX2-RootCD-2012.iso link it takes me to Mediafire. When I click to download the file it either: 1. reloads page and download button. Or, 2. saves to My Downloads from (after I decline the FULL-DISKfighter advertisement)...but it never actually saves. The transfer rate continues to say "calculating" the whole time.
Upvote 0
I know this is the most common topic here (kinda), but none helped me.
I own an Android 2.3.4 Build GRJ22
It is Qmobile A5,google it... cant post the link
Now the problem, I tried to root it with SuperOneClick Root at least 10 times but the app hangs (for an hr) then I had to force Close it.
I tried to find every where but it did not seem to help. Hoping to find some answers here.
I have rooted many phones before including HTC, Motorola and Huwaie, but mine one seems to work on it. even z4root froze and force close dialog appeared.

My PC Specs:
  • P4 3GHz HT
  • 3.5 GB RAM DDR2
  • Windows 7 Professional x64

Phone Specs
  • MT6573 650 MHz Processor
  • 213MB RAM
  • Android version : 2.3.4 GRJ22; Release Codename : REL; API LEVEL : 10;
Can I root my android with your software? Is it safe to do so because i cant download a recovery image as none is made for it.

Salik Sadruddin
Upvote 0
I just got a second-hand DX, and having a hard time getting root. At first, it looked like it worked, so I installed Bootstrap for Droid X, and flashed Ky's modded 621. Then ran into a bad loop upon setup, and had to SBF. I'm trying the whole process again.

Upon beginning the root process after booting this cool linux live CD, it gave an error very early on, something about an /MD5 not being found, it but continued the root process right through to the end. Could this have had something to do with the problems I've been having? If I continue to have problems, how could I correct the issue?
Upvote 0
Ah, there's the rub. After using Ubuntu live to SBF the 621 file here from 1KDS, I wiped cache and did factory reset. I then applied root using the ezCD method and the multi-device live-boot Linux CD, selecting to root the Droid X (with USB debug and non-market apps enabled). I wiped cache again, just to be safe. I installed the Droid X Bootstrap. But Bootstrap gave me a blank screen. I could select anything - backup/restore, flash zip file, reboot, wipe cache - when I hit the power button to execute, I got a blank screen and had to pull the battery.

For some reason, the Droid 2 root CD did not work for me - it got a kernel panic every time I tried it yesterday. I was able to load the 604 sbf, but that's not where I wanted to be.

BTW, the loop I was referring to above was not a boot loop, it was a setup loop. I was stuck setting up accounts, and it would not let me say "done setting up accounts." Can't figure that either. Anyway, stock SBF set that right.

After getting root, I was able to freeze a bunch of bloatware with Titanium Backup. I was able to boot to recovery. But once in Bootstrap recovery, I could go nowhere. I wonder of Bootstrap is flawed, because the rest of the system seemed okay. I had done full wipes, so the system should have been clean. Heck, I rooted over a system that didn't even have any user set up, I skipped setup and only turned on USB debug & allow non-market apps. Oh, and having the phone on 'charge only' did not work for me; I had to set it to PC mode. I'm running through the whole process again now. The one glitch in the process, at the very early stage of running the root says: rm failed for /data/preinstall_md5/magic md5/magic.md5. No such file or directory. (there's a letter missing at the beginning I can't make out, because it's off-screen). It doesn't do anything at that point, but then I reboot to bootloader, and it proceeds normally.

Thanks for looking at my post.
Upvote 0
I am just not getting a good root out of this. Tried again, and this time TiBu couldn't get root access, even though SU was installed & updated, and Root Checker said I had root, and I could rummage around the root directory with the ES file manager. Last time, it was the failure with Bootstrap (which I didn't even try this time, if TiBu didn't work). Man! Maybe I'll just stick with my Eris! Could it possibly be that, as another person suggested somewhere else, a Motorola-brand USB cable is necessary? (the cable I'm using is Pantech, but has a Verizon V-cast tag on it, so I thought it would be okay) Or, isn't there a pre-rooted 621 sbf file somewhere I can plug in through Ubuntu?
Upvote 0
i'm guess in tibu didn't work because you missed the allow/deny time, sometimes happens
open superuser and change tibu to allow

cable may be an issue, but if sbf went fine, root should work

also could try updating superuser, if you can go through all the update steps you are rooted
or use root basic or voodoo ota to verify root status

isn't there a pre-rooted 621 sbf file somewhere I can plug in through Ubuntu?
not that I know of
just this and the 1kds milestone 604 ezSBF
Download - 1KDStaz_MX_4.5.604.iso (Milestone X 4.5.604 Gingerbread)
210.8mb (210,763,776 bytes)
MD5 (1KDStaz_MX_4.5.604.iso) = b8d32cfca4d138f3076b0bf85ae6318e
This is a special image. It is used for those that have taken the 4.5.621 OTA update and have lost root. This image uses the nTelos Milestone X 4.5.604 sbf file. This results in a non-Verizon system but you are able to use ZergRush (included) to root. Only use this file if you are on 4.5.621 or already on 4.5.604.

someone with a x2, had trouble keeping root and flashing roms
I made a nandroid of my eclipse rom, he was able to flash that, and keep root
you could try something like that, post in the rom thread you want, and ask if someone could upload a nandroid to mediafire or db
not a great option, but it may be your phone, has a hardware problem
  • Like
Reactions: BSH
Upvote 0
Thanks themib. Hardware problem is definitely possible - after all, it's an Ebay phone ;)

Before I go mucking up my (currently) good root by installing Bootstrap, let me ask a couple more questions. I bought the Droid X version of Bootstrap, but I've seen other threads where people install the D2 version. Does it make a difference, if so which is better for the X? If I have Bootstrap, I don't need Rom Manager, right? Does Rom Manager substitute for Bootstrap, or no?

Thanks again.
Upvote 0
Okay, this phone just won't work with CWM at all. I followed those directions exactly. Rom Manager would not boot to recovery, only to a regular phone reboot. Quick Boot will boot the phone to regular phone recovery, but not CWM recovery. I go into Bootstrap and tap "bootstrap Recovery" and it says success. I hit "reboot recovery" and it boots into recovery, but has the same problem as before. Selecting any item and pushing the power button to execute leads to a blank screen. Hitting power again brings back the recovery menu screen. I have root, but I can't even make a Nandroid backup (or restore one, or flash a zip file, or even reboot) because I don't have CWM recovery.

I accidentally bought two DXs on Ebay, so I'll be interested to try this process on the other and see what the result is. I may have to give up on flashing any alternative rom, but just be satisfied to have TiBu functional.

Thanks again for your help.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.