• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Error copying files from PC to S10e using USB cable


Dec 29, 2021
I have a weird issue when trying to copy multiple files from pc to phone, using an USB cable. In about 95% of cases, the copy process gets stuck at a random file... ("Copying..." and the file name is displayed meanwhile). After some time I get an error message "Cannot copy file <file name> . The device has either stopped responding or has been disconnected. Stop copying? / Skip this file / Cancel" . The file is always a different one.
The more files I try to copy, bigger the chances to fail. If I choose Skip, the copy continues but chances are it will get stuck at another file and so on.
Files are pictures, movies mp3s, it doesnt't seem to matter.
For the moment, the workaround is to repeat the copy process until the number of files in destination matches the source...
I can copy just fine anything (lots and lots of GB) from phone to PC, using the same USB cable, without adjusting it, before and after the failed copy from pc to phone.

Phone is Samsung S10e up to date
PC is a Windows 7 x64, all 4 USB ports behave the same.
USB cable looks fine as far as I can tell

I wonder if someone experienced something similar or has some idea on what to check.
For the next week I am limited to the hardware mentioned above.
Changed cable, no difference
Tried on another win7, same behaviour (error copying to phone, on random files)
Tried on win 10, copy from phone fine, copy to phone does not show error, yet randomly some files are not copied to phone (?!).
I used windows explorer to copy. Phone has only internal storage.
There are many ways to transfer files, let's not get into that.
Please refrain from things like "you're trying to copy too much data"... it's neither constructive, and not very smart either.
Healthy hardware and software should not show errors and work as expected.
Upvote 0
You cannot just make things work as you expect them to.

If that was possible, then you would have copied your files already and not needed to post here again.

You have tried all the things that you have wanted to try, with failed results- yet refuse to try any of the suggestions given, as simple as they may be- like trying to copy smaller amounts of data each time or using a different method.

I never had any luck trying to do what you want the way you are trying, and so I found NitroShare and use that instead.
My problem was solved, although I still need to limit the quantity of data to transfer at one time.

Data does not always transfer in order, one thing at a time.
Sometimes things get jumbled, and then are sorted out at the other end.
When you transfer large amounts at one time, you increase the number of parts transfered and also increase the chances of them not being sorted properly in the end.

And what are you using to look for these files that are 'not copied'?
Is it possible that they ARE copied and you are not finding them?

If there is a '.' in the beginning of any file or folder, that will be considered a hidden file on Android.
Stock file managers are notoriously crap (like My Files) and if that is what you are using then a better one is in order.

For what it's worth, it is neither smart nor constructive to tell people you have asked for help how you would like them to answer.

Many answers to life's questions are things that we do not want to hear or do.
Upvote 0
To everyone trying to help, thank you for your time.
I am a programmer, and not superstitious by nature. So I would appreciate technical info on the issue.
Like I said, copying is a basic operation that should work reliably using a USB cable for 5, 50, or 500 files.
I just got a confirmation from someone that the exact same operations (with the exact same files) work fine with another S10e. So I would like to receive info on the cause of the issue and potential fixes.

Other than that, of course everyone is free to answer whatever he/she likes, I am just explaining what I would like to know...
Last edited:
Upvote 0
Did this other person use your computer, your cables, and your programs and apps?

Is the phone absoultely identical- because even the 'same' phone can be very different just between cellular providers.

Check this one out...
My ol'lady and I have the exact same phone.
Same specs, relatively the same manufacture date, etc.

The difference?
Hers is from Tracfone, and mine is an unlocked model.

The biggest difference is that hers has a replaceable battery, whereas mine does not.

This would be a huge difference, correct, (?) in two 'identical' devices?

Also, Samsungs have two processors available for their phones, and many small differences between what would appear to be identical devices.

See if that person can bring the other device to your home and replicate the success, using your equipment and first one phone then the other.

Or you go over there and try the same thing.

Or you could try another method altogether, which is what I had to do for myself.

Wi-fi transfer works for me, and it is wireless and fast.
  • Like
Reactions: Dannydet
Upvote 0

I noticed you have been doing this from Windows 7 machine and getting same results. I don't experience your problem specifically, however, I did have Windows 7 issue recently relating to USB ports on my old laptop that may be worth inspecting.
My issue is that one of the three USB ports on my ASUS was no longer being recognized by even the Windows OS; I discovered it while plugging my Samsung into that port. For the longest time I couldn't figure what happened because I don't abuse the ports, and besides that the laptop had been idled over a year since I use a Windows 10 machine mostly now.

Finally, I was testing out a version of Linux from a USB stick on that laptop (on a different port) and to my surprise Lubuntu was able to access that port. That tickled my curiousity to research the Windows 7 side, discovering that a Microsoft firmware update downloaded sometime recently had mucked up the USB subsystem, leaving me only 2 out of 3 working ports. I rolled back all those firmware drivers I could find until the dead USB port came back online.

I've no idea if you may be suffering a similar firmware driver update that affects your USB subsystem, but it's worth considering.
Upvote 0
All 4 USB ports behave the same, tried already on 3 different computers.
Cannot reliably copy from Win 7 or Win 10 to phone; difference is that win 7 displays that something went wrong with the copy process, win 10 says nothing but fails to copy some of the files and hides the trash under the carpet.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.