• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help External Keyboard will only type English

Preacher Al

Lurker
Aug 18, 2021
4
4
I need to type in multiple languages. But for some reason a couple of years ago some update, made it impossible to do so from an external (Bluetooth) keyboard. I tried to report the problem through Google but because I was having the problem on a Samsung product Google basically said, "Sorry not our problem." Samsung was no help at all. Now with my new Google Pixel 4a, it is doing the same thing. If I push (CTRL) + Space it shifts the language of the Google keyboard, but the external keyboard only types in English (Device default language). They only way I have been able to get it to switch languages is to go in the phone/tablet settings and change the language there. Way too much trouble. I need to be able to switch keyboard languages on the fly, mostly because I am studying Russian on Duolingo. But occasionally I need to switch back in forth between English and Russian/Ukrainian when writing documents.

Is there a patch out there some way or is this a problem with the Android O/S?
 
Probably the least amount of effort would be to use a better keyboard app that supports multiple languages.

I would look on F-Droid, keyword 'keyboard' and possibly adding the language(s) you want (one per search) and try multiple ones.

https://f-droid.org/
but will that work with an external bluetooth keyboard? never tried one so i do not know if they require an additional app to be used.

op have you looked into changing the languages in settings?
 
Upvote 0
pk, Google Keyboard supports multiple languages. What is bizaar is that when I elect to have the on-device keyboard show, I can see it change between the languages I have installed, but it still only types in english. Like mentioned earlier it happend after some update a couple years ago. Is there some way to put a bug in the ear of the Google people about this? Thinking some setting needs to be toggled in the OS
 
  • Like
Reactions: ocnbrze
Upvote 0
Okay solved it. Whatever Android update it was it changed it so you have to enable the physical external keyboard for other languages through system settings. It isn't enough to set them up through Gboard anymore, now you have to select them for the external keyboard itself. I stumble on it when trying to fix the issue using Gboard's recommendations. But you can only do it while the keyboard is linked to your Android device.
 
  • Like
Reactions: mikedt and ocnbrze
Upvote 0
Hello Lurker, did you find any ultimate solution to the problem? As in how to solve this problem for universal devices?
Lol the members name is @Preacher Al. The "lurker" is a title given to AF members who does not have a lot of posts here in the forums.

This thread was his only activity here, unfortunately. So I doubt he will comment on your post.

Can you post what is exactly going on for you? Is it about an external keyboard and using a different language? If so what phone do you have? What external keyboard do you have?
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones