• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Fixed My Wifi not connecting problem


Android Enthusiast
Nov 8, 2009
I just bought the Bionic yesterday to replace my DX. One of the many reasons I wanted to replace it was because I was getting really tired of having extreme difficulty connecting to wifi on my DX. If I used a widget, it would either not ever connect, or it would take a minimum of 5 minutes to connect. I have the sonos music system throughout my house and I have to be on the wifi to be able to control it. Every time I came home it was a hassle to get it to connect. I found that I just couldn't use any widget. I had to go in to setting wireless networks, turn on wifi and select my system. This got old! Imagine my surprise that after getting my bionic up and running, IT DID THE SAME THING! Now, I travel for a living so I stay in a lot of hotels. No matter where I go, I always looked for a wireless network I could connect to. Google will then remember all the networks you have saved passwords in so that when you back, you can automatically connect. I decided to go into my settings and "forget" all networks. There were probably 75 different ones that were saved. That fixed it! I added my home network again and it now connects within about a second using a widget. I even went back to DX and did the same thing. That one is also working just fine.

There is a good chance that this is something that only happened to me, but I thought that if this were to help just one person from going insane like I did, then the post is worth it.


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.