• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Galaxy Nexus Charging Issues

I bought a Galaxy Nexus at my Verizon store on Black Friday 2012. Love the phone and it worked flawlessly for several months.

Then suddenly I noticed it wouldn't charge all the way.

Went to the Verizon store, and was told it's picky about what kind of charger it uses, and the one that came with it must have gone bad. Shelled out $30 for a new one. That solved the problem.

Over the next couple of months, I started noticing a few buggy issues. I could no longer send my daughter pics. Then every now and then a text would not go through but it would be up to a couple of days before I got that notification. Then the Navigation would stick in "Searching for GPS" mode.

Went back to the store, they ordered a replacement phone. Got the new phone, charged it up, downloaded all my apps again. Over the next two days, I noticed that it was dying earlier and earlier in the day. Finally figured out that it wasn't charging up all the way over night. Again.

Back to the V store. They keep it for a few hours, trying different cords, plugs, etc. Nothing works. They swap out my cord and send me home. (I had two different workers, so I didn't know that they'd made all those tries until my next trip to the store.)

Finally, I go back to the store, asking that this time they replace the battery, because obviously the cord solution isn't doing the trick. This is when they look at the battery charging meter and it shows that my phone has been running on battery for days, meaning it was never on a charger. Not true. They try to get me a battery, but there are none in the warehouse. They send me to BatteriesPlus for a battery. I buy it, they reimburse me. I go home, plug it in and I still have THE SAME ISSUE.

This time I call Verizon support. They don't have a clue, but are sending me a new phone. It will be here tomorrow. My guess is, it won't work either because from the internet searches I've done, this appears to be a software issue with the 4.2.2 update.

Is anyone else having similar problems? Have you found a resolution? I'm about ready to go back to my Droid X and forget the whole thing.

Thanks for any suggestions!


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.