• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Gingerbread and Wi-Fi don't mix

Please send an e-mail to the following people (the senior management team at HTC) if you want this fixed it will take you 1 minute and will make a real difference just copy and paste the below. Then change the e-mail text a bit before you send.

jon_french@htc.com, Cher_Wang@htc.com, John_Wang@htc.com, Keith_Nowak@htc.com, Peter_Chou@htc.com, Lotus_Chan@htc.com

Dear Sirs,

You have a major problem with the HTC gingerbread update that you have rolled out in the UK. The wifi no longer works for me as it keeps disconnecting. Many others have the same problem. I used my phone for about a year before this and the wifi worked like a dream. It is unacceptable that this vital function no longer works properly. Please let me know how you intend to fix this. On another note you have major problems with your HTC Sense website despite heavily promoting it. I look forward to your response.

jon_french@htc.com UK CEO
Cher_Wang@htc.com Chairman
John_Wang@htc.com Chief Marketing Officer, HTC Corporation
Keith_Nowak@htc.com Senior Public Relations Manager at HTC
Peter_Chou@htc.com CEO
Lotus_Chan@htc.com VP HTC

If you send an e-mail you will be a making a big difference.
Upvote 0
I've already e-mailed via their website, but I will e-mail direct later on today.

Good e-mail, bh27, but I think it might be wise to include some more information on the problem so they know exactly what we're talking about. Specificially, that the wi-fi drops perfectly useable signals below -88dbm - rather than 'it just doesn't work'.

In fact, someone on XDA forums posted this rather good e-mail, which provides all the info...

Dear HTC
I recently upgraded my Incredible S from 2.2 to 2.3.
Before the update, the phone would hang on to the quite low but useable wi-fi signal in my bedroom, but after the update the wi-fi disconnects and puts the phone on 3G.
My old HTC desire still holds on to the signal fine, whereas my new Incredible S loses it. (both at around -90 dBm)

After a lot of research on forums, I have noted that this is a very common problem, and many people are suffering from poor wi-fi since the 2.3 update. I suggest that you take this problem seriously.

We have localized the problem to a change in rssi threshold to -88 dBm. That is strange as this is a perfectly useable signal strength.

It is suggested that this code "error" is part of a Broadcom driver update, and not HTC's fault
You can find the code snippet here:

Please forward this mail to your dev tech department, as this needs to change as soon as possible
People expecting an upgrade, actually got a downgrade with gingerbread

yours sincerely

Related posts:





  • Like
Reactions: bh27
Upvote 0
I got this phone (on 2.3.3) 2 days ago and noticed that WiFi was a bit flakey... but then also realised that it took down the wireless switch!

Whenever I connect my phone's WiFi to the switch, I can't get into the portal on the switch (via LAN cable) and no other WiFi devices can continue to use WiFi!

Don't know if the switch being brought down is due to the same issue that's causing everyone else here to drop their connections but... :mad:
Upvote 0
I've just blogged about this problem.

My solution has been to purchase the Tasker app, and set up a rule to disable my data connection when in range of my home wifi. It works well, but is kind of hacky.

I'm now manually disabling my mobile data once wifi is connected. Seems to have fixed the issue, and I now get fantastic wifi reception all around the house. I'm going to hold off spending
Upvote 0
My new HTC incredible S cannot connect to my home wireless router, i changed radio channel and encryption type but to no avail, took me two full days to find the solution.

I simply reset the router to factory settings by pressing the reset button behind the router then using the computer attached to the router, from d browser enter the url to set up d router, set it up by entering your Internet login user name and password and enable the wireless feature, i tried to enable my Incredible S wifi and MAGIC! ....my Incredible S is now connected to the router and the internet. hope this will help you too!
  • Like
Reactions: tpbklake
Upvote 0
This was the latest update from HTC Customer NoSupport.

I am sorry but this is pathetic... now they are blaming the hardware design. Whatever it is, its a shit phone!!!

Their reply:
Since there is a death grip on the HTC Incredible S, we would suggest you to pay attention when using it. For example, you can take the buttom of the phone so that your hand won't cover the antenna.

Sorry for the inconvenience.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.