• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Gmote 3G usage connection question

ToxicToastKatz

Android Enthusiast
Oct 3, 2009
365
37
Aurora, IL
ok, so I'm pretty good at following directions, but I'm pretty bad at networking issues with computers :)

I have Gmote installed on both my home and work computers. When I am at home or work and connected to the WIFI networks respectively, I generally don't have any issues connecting to those computers with my phone.

I am attempting to utilize the 3G connection for my home computer, so that if I'm out and want to connect to that server, I am able to.

I went into my router's settings (I have a Netgear WGR614....or something like that) and went to port forwarding, I added a new connection and titled it "Gmote", set the in and out ports to 8889 (made sure it was both TCP/UDP); and then did the same for "Gmote Touchpad" setting both in and out to 9901; applied the settings and logged out.

I got to work today, turned the WIFI off (so that I'm not connected to my works wireless network) and searched for the server. I chose to enter it manually and changed only the IP to what my local IP address is on my computer at home. After hitting done, it still won't connect.

FWIW, I have an iMac at home that I am trying to connect to. I haven't done anything with the firewalls yet. Is there a connection error that would alert me if the firewall was the issue?

Does anyone have any insight as to how this can be resolved? I appreciate any help anyone can provide.

Thanks guys.
 
your network at home is probably in the 192.168.x.x range.. if so that's a private network and cannot be accessed outside of that network. to get around that, go someplace like dyndns.org and setup a dynamic domain name (it's free) then have it point to the IP of your router (cable/dsl/whatever). in your router open the ports needed and point them to the IP of the PC/Mac you want to connect to.

i.e setup account at dyndns.org... have trhat point to your cable/dsl IP xxx.xxx.xxx.xxx (if setup from your Mac at home it should find the true IP for you) on router port forward 8889 to the ip of the Mac on the internal network 192.168.xxx.xxx

it should now work when connecting to domain.dyndns.org:8889
 
Upvote 0
your network at home is probably in the 192.168.x.x range.. if so that's a private network and cannot be accessed outside of that network. to get around that, go someplace like dyndns.org and setup a dynamic domain name (it's free) then have it point to the IP of your router (cable/dsl/whatever). in your router open the ports needed and point them to the IP of the PC/Mac you want to connect to.

i.e setup account at dyndns.org... have trhat point to your cable/dsl IP xxx.xxx.xxx.xxx (if setup from your Mac at home it should find the true IP for you) on router port forward 8889 to the ip of the Mac on the internal network 192.168.xxx.xxx

it should now work when connecting to domain.dyndns.org:8889

WOW!! I would have NEVER figured that out :)

I will give it a whirl when I get home this afternoon.

Thanks for the tips.
 
Upvote 0
your network at home is probably in the 192.168.x.x range.. if so that's a private network and cannot be accessed outside of that network. to get around that, go someplace like dyndns.org and setup a dynamic domain name (it's free) then have it point to the IP of your router (cable/dsl/whatever). in your router open the ports needed and point them to the IP of the PC/Mac you want to connect to.

i.e setup account at dyndns.org... have trhat point to your cable/dsl IP xxx.xxx.xxx.xxx (if setup from your Mac at home it should find the true IP for you) on router port forward 8889 to the ip of the Mac on the internal network 192.168.xxx.xxx

it should now work when connecting to domain.dyndns.org:8889

so just to clarify, after setting up the account on dyndns.org and pointing it to the Cable/Modem IP, then opening the ports on the router to point to IP of the Mac, I search for the server in Gmote and it wants me to manually add an IP...do I enter the IP from dyndns.org? Because the other IP isn't working.
 
Upvote 0
I just went through this the other night. I had port forwarding set up on my router, but NOT on my modem. Also, my router has a firewall, I had to add my computer to the exclusion list. It was referred to as a DMZ on my settings. To access my modem (yours is likely different) I had to go to 192.168.254.254 good luck! It's awesome once it's working.
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones