• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Google Calendar won't sync since 2.1

Found this fix suggested by hondamec on another thread. It worked (except that it's now called "calendar storage":

1. Go to Settings -> Data Synchronization -> Google and uncheck Calender

2. Go to Settings -> Applications -> Manage Applications and find
com.android.providers.calender & Calender, go into both and clear the data.

3. Go back to Data Synchronization settings and check Calender again.

It should sync this time without crashing, and you should see all of your calenders with complete data.

Hope this helps
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.