• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

google play store


Jan 1, 2013
I've had my Nexus 10 for just over a month now, working all fine, not rooted or anything.

I'm in the UK.

Since Yesterday, the Play Store launcher is refusing to get past the loading screen on my home LAN (not tried any others). I've rebooted my router and Nexus, added port 5228 to my router - but still nothing.

Any ideas?

Can still use the play store via the web, but its a real pain.:(

Thanks for the welcome:)

Tried that, also did a force stop, but still the same.

Created a new user, and resigned on, and hey presto, it worked on the second account. When switching to my prime account Google Play failed. Had a look in the Google accounts and it seems there was a sync issue, all glowed red :thinking:

Nothing seemed to fix it. So done a factory reset, seemed the only sane thing to do!

Perhaps I should root and backup.......
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.