• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Google Voice incoming calls won't ring

raudesign

Lurker
Dec 13, 2021
1
0
Hi, I'm new to Android and tried to set up Google Voice. When I call my Google number using another phone, my Android phone only shows a notification, vibrates, but doesn't ring. My goal is to have it ring like a regular phone.

All my devices are toggled to on (green) under "Calls > My devices". My iOS device and my Web browser both ring. I tried toggling all of them off, tested, and turned them back on, tested, it still did not ring.

I tried removing "Linked numbers" and relink, it did not ring.

"Devices and numbers" has the Android device listed.

The phone is not on DND mode, my regular incoming calls ring.

Google support says I can customize ringtones by going to Google Voice's "Settings > Calls > Incoming call notifications > Sound"; but there's no such option as "Incoming call notifications" under "Settings > Calls". There is "Message notifications" under "Settings > Messages" though.

The Android phone can receive the calls by pressing "Accept" on the notification.

In summary, when someone calls my Google number, my Android device only shows a notification and vibrates. I want it to ring, just like receiving a regular call, just like all my other iPhones and iPads and browsers. And again, all of them ring to the same call I made, the only device that did not ring is my new Android device.

I thought Google on Android is supposed to be straight forward, but everything has been extremely difficult so far. I've spent hours on forums looking for answers as if I'm fixing Windows 95 in 1998 lol. Am I doing something wrong? Please help! TIA!
 
In settings, where it says incoming calls notifications, is that enabled ? and if it is, and if you don't see notification settings, scroll further down, see if you have an advance tab, if you do, hit that and check if it gives you notification options.

If you still don't have these options, only other thing I would do is, clear cache, force close and then clear data, and start from fresh and see if that helps or works.
 

Attachments

  • 1.jpg
    1.jpg
    68.1 KB · Views: 193
  • 2.jpg
    2.jpg
    144.3 KB · Views: 202
  • 3.jpg
    3.jpg
    167.1 KB · Views: 435
Last edited:
  • Like
Reactions: Dannydet
Upvote 0
My Google voice could receive voicemails but would immediately go to voicemail when someone would call my Google voice phone number. I looked through all the app and Android settings: notifications, sound, do not disturb, etc but found nothing that worked. I search the internet, Google help, quora, reddit, tech support websites, and I could not find this answer.

Finally after redoing all the settings in Google voice, I found the text hidden in the Devices and Numbers -> new linked number or "set device number" screen:

(All) Inbound calls to your Google voice number will be forwarded to this (linked phone) number.

The first time you try it to dial a phone number through Google voice in your Android app, a pop-up prompts you to link your phone number / set up your device phone number for Google voice. If you do this, then all of your phone calls will always be forwarded to that linked number. There is no setting anywhere in the settings to turn this forwarding off. The only way is to delete the linked phone number.

Since this answer could not be found anywhere on the internet, and there were lots of people having the same problem, I wanted to share the answer here.
 
  • Like
Reactions: ocnbrze
Upvote 0
.....

Google support says I can customize ringtones by going to Google Voice's "Settings > Calls > Incoming call notifications > Sound"; but there's no such option as "Incoming call notifications" under "Settings > Calls". There is "Message notifications" under "Settings > Messages" though.

.....
It is odd you don't see that Incoming call notifications menu in your Google Voice app Settings menu.
I'm looking at the Google Voice app on my phone when I tap on Incoming call notifications in the resulting page it includes a Ringtone option. Tapping on that results on a list of available sounds to pick from as the default GV ringtone.
Perhaps you just need to double-check the Settings menu in your GV app for Incoming call notifications, and be sure to select a ringtone.
 

Attachments

  • screencap1.jpg
    screencap1.jpg
    39.5 KB · Views: 53
  • Like
Reactions: ocnbrze
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones