• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Having problems with my milestone... :(

I upgraded to a milestone a couple of months ago after lusting after one for a very long time. Worked like a dream for ages, but recently has got very slow and unresponsive with things such as when you enter a name in the 'to' field when wanting to send a text message. I tried clearing out my texts, deleting apps, had no effect. I also use TasKiller to see what's running to free up battery. I updated the software. I did a Battery Pull just now and my phone is taking a stupidly long time to switch on. I know milestones normally take an age to load, but it's normally like 1-2minutes, and it's been loading for almost 15 minutes.

Please help :( I'm with Vodafone but upgraded through Carphone Warehouse.
 

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones