• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root headset not working right...


Android Enthusiast
Mar 29, 2011
Washington DC
one for your smartypants out there. I have a new (refurb.) and wanted to get a new headset from VZ. Went to the store, worked fine on BAMF109. Then switched back to Blksource AOSP and you have to hit speaker on and off to make work.

Then, wiped everything and loaded brand new Blksource to see if it might be a software/setting conflict. They worked perfectly. So, i have a self inflicted injury...i searched all through the settings on the phone trying to see where I might have the wrong thing selected (plus apps settings - sound, music, pandora etc). Can't figure out where the problem is. Before I go all the way back to square one and reload everything fresh, thought I would see if someone had the easy fix.

Well, here's my update, reloaded stock AOSP rom and headset worked fine, then didn't. But, would work if I toggled speaker on/off. When I toggle off, the headphone speakers work. Must be a tiny bug in the programming for recognition. Anyway, toggling is not a big inconvenience, so I loaded up my nandroid backup and I am going on with my day.

Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.