• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Home Page Google redirects

Exris

Lurker
Feb 8, 2011
3
0
Latvia
Hello,

Little issue what having on mine phone browser on HTC Wildfire with Froyo bought in Latvia (and I'm also using it in Latvia).

I have chosen mine Home Page www.google.com but always as open web browser it redirect to www.google.lv, what provides usually different search results. I'm not interested in this results. Logged on with Google account, where on PC is opening only .com page. Tried to switch in Google settings chosen language (language change but domain left as .com). Disabled location check in Google setting and disabled even on mobile browser these setting, but still redirect to .LV domain.

It's quite annoying when every time its needed to return to English page.

Any suggestions how to deal with it?

Thanks
 
Welcome to Android Forums, Exris.

If the homepage redirect is not being generated by your carrier, you can remedy that issue by clearing cache, data and defaults in the browser's application manager.

Menu > settings > applications > manage applications > menu > sort by "all." After all of the applications load, find the stock browser there and click it; you'll then see cache clearing and data clearing buttons, and sometimes the "clear defaults" button is available as well.

Once done, reboot your device.

An alternative to doing all of that, and a clue as to if your carrier is redirecting google.com to google.lv, is to simply download and install another browser from Market, such as Dolphin HD, one of the best there is.

Let us know how things are going. :)
 
Upvote 0
Menu > settings > applications > manage applications > menu > sort by "all." After all of the applications load, find the stock browser there and click it; you'll then see cache clearing and data clearing buttons, and sometimes the "clear defaults" button is available as well.

Did not worked, same redirection occurred. Found in help Google some tips that cookies should be enabled (were on mine in browsers) and third part cookies could be the reason, some browsers are not accepting them or just not able to accept them. But I doubt that this is main cause.

Well, others browsers also did not help. Except Opera Mini, strange that there wasn't this redirecting with shown Google error that cookies not activated, but it was loading longer and wasn't available quite many others function and options as in other browsers.

At moment looking for any others options and causes.
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones