• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

How do I stop my phone from notifying me whenever a new network is available.

on my z fold 3: settings>wifi>3 dots top right corner>advanced>toggle off "network notification"

i doubt on your phone that "network notification" is found exactly as mine. but you can do a settings search for it.
I don't have the three dots. I've searched under "network notifications" and nothing comes up. If I search "network" I get "Select best networks automatically" again along with other stuff. There's an option not to warn me about data usage when switching to mobile data, but I don't think that's what I need.
 
Upvote 0
There's often two versions of the same notification and only one can be turned off that I'm aware. The first is the notification with a Wifi icon with question mark that when revealed, says 'a public wifi hotspot is available'. Tap and hold that notification and see if you either get 'more info' (Android 4.x), a switch to disable notificaitons (Android 9+) or a link to settings that takes you to the notifications section for said service, and if it cannot be switched off (much of this in modern Android) look for an 'alert' or 'silent' option. When you select 'silent' you should also see 'minimize notifications' which disables the notification icon and lockscreen notification and only shows it when you swipe down to reveal the notification area.

The second is oftentimes when you just switch Wifi on (or Bluetooth and there's a simlar one for that) but can pop-up any time it wants (On Samsung's mainly) and it's a pop-up box with a list of wifi (or bluetooth devices) to choose. That annoyance was quite frequent on my Galaxy S3 and S4 and I never found a method to disable that other than just keeping Wifi/Bluetooth off.
 
Upvote 0
Thanks. I'll try to catch one of these notifications and see what it's all about next time. The problem is I'm normally on my bicycle when they go off and it's not convenient to stop. I fear I will just have to live with them though. Pretty stupid of whoever added this to the platform though.
 
Upvote 0
It was added because way way back then, unlimited data plans didn't yet exist (in the US) so wifi was almost always preferred by apps (even hard-coded into early versions of Android Market/Play Store, forcing wifi to be used to download certain apps over a specific size) over mobile data. In earlier versions of those apps and devices, you'd often get pop-up warnings when using mobile data that it might incur data overage charges. Those were quite expensive so I understand why it's there. But it's not 2010 anymore, and Google, while not relying as much on wifi, haven't removed that code in the source.

Heck, I remember when texts were charged by the letter (SMS on then-Cingular Wireless circa 1997) and if you ever wondered where 'txt sp3k' came from, that is it. Saving letters by abbreviating them saved $$$ to send a message. A simple 'r u thr?' was a nickel and penny, while 'Hello, are you there?' was 18 cents.
 
  • Like
Reactions: Milo Williamson
Upvote 0
I don't think I can do anything about it short of turning the sound down. It went off as I was cycling today and I stopped to look for the notification. It was telling me that I was connected to Starbuck's wifi. There was no option to turn it off associated with the notification.

I do prefer using wifi where it's available as it seems quicker and more reliable when it's available than the phone network. Plus the phone network can cost money, I've no idea how much. So I appreciate the fact that my phone now connects to the wifi automatically.
 
  • Like
Reactions: Milo Williamson
Upvote 0
I don't think I can do anything about it short of turning the sound down. It went off as I was cycling today and I stopped to look for the notification. It was telling me that I was connected to Starbuck's wifi. There was no option to turn it off associated with the notification.

I do prefer using wifi where it's available as it seems quicker and more reliable when it's available than the phone network. Plus the phone network can cost money, I've no idea how much. So I appreciate the fact that my phone now connects to the wifi automatically.
Head to system settings > Auto connect to wifi and turn it off :)
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones