• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help HTC email client not sending on WIFI

I could not receive email via Google or Exchange. I had my lT company look into and they resolved it. I asked him to email me what he did. Here is his response:

"Because you were in a domain setting I had to create an internal dns entry that corresponded with your external mail ip address. This way when you were inside the network you would stay inside the network to send an receive mail."

Don't ask what all that means, but it works now.

Now if only HTC can fix the FWD'ing as attachment issue!
Upvote 0
For what it's worth, I've seen none of the symptoms described here. I use WiFi at home with a Linksys WRT160N Wireless Router behind a Netopia/Cayman 3346 DSL Modem/Router/Firewall (I subscribe to BellSouth/AT&T DSL 6 Mb/s). I've experimented with trying various things with the WiFi off, seeing how it performs with EVDO (so-called "3G" mode; no "4G"/WiMAX in my area (Ft. Lauderdale, FL, US)), then turning on WiFi to compare performance. Other than speed differences, I've experienced NO differences in functionality. Things work (or don't) the same using either connectivity (other than access to nodes on my LAN that are inaccessible from outside the firewall).

The port-blocking for SMTP (port 25) by BellSouth (now AT&T) has been going on for several years, so I use SSL authentication/encryption which uses port 995 by default. This port is *not* blocked, so it's all happy.

I'm on a Sprint/HTC EVO with the OTA update applied to 1.47.651.1

BTW: I strongly recommend setting this up on a mobile client, because, by default, all SMTP (port 25) traffic is "in the clear". Anyone packet-sniffing can read your (supposedly) private Email you're sending.

Similarly, if you're using POP3 (port 110) for Email retrieval, then (most likely) all of your retrieved Email is also open to be read by anyone snooping on the same network as your mobile device (WiFi or office LAN).
Upvote 0
I had same problem but only on my office WiFi. It had to do with exchange and how our internal address and DNS outside worked. Our IS company that I work with fixed it. Not sure that helps but I could not receive but could send. Opposite of your issue but it may be related. I am on vacation until Tuesday so I can not be any more specific. If neededi can find more out then.
Upvote 0
I have the same issues .when using htc inspire email client I have to either check or unchecked require authentication password .im ising time warner t wcny.rr.com email I like to use wi-fi because it uses up plus my data plan .I can receive emails either way wi-fi or to the network no problem .it's when I go on wifi I cannot send my email unless i change settings in email seup check or unchecj require authentication when I go back off wifi I'll have to change it back to the other settings so I can send em ails again .it's a real pain in the a**. Htc/droid needs to updat email interface so I can have a setting for each wifi and network both . until htc android ficx this in software update . we will have a problem that's the bottom line. They need to fix software on the phone .
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.