• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Idiots Guide To Rooting Kindle Fire HD 7" 7.2.3


Dec 26, 2012
I was originally going to post this in the existing thread titled: [ROOT] Kindle Fire HD 7" started by PRallday168, but decided to create a new thread instead. This guide is based on that one, but goes into more detail, aimed at those folks unfamiliar with the process of modifying anything.

Sometimes we get a bit frustrated when trying to do something we have not previously attempted, following guides that make an assumption that you already know at least part of what you are supposed to do, leading to confusion and mistakes. So here is the "Idiot's Guide To Rooting Your Kindle Fire HD"
With full academic ethics I will reference all other folks work and provide links when required.
This post will constantly change as new information comes to light
Thanks for input from Rollout regarding use of the SDK

Section 1 Prepare your PC (Windows7 and XP)

On your PC: Items in Braces {} refer to Windows XP
Firstly ensure you can see everything Bill Gates did not want you to see:
1) Open Windows Explorer (Double-Click on the "Computer" {My Computer} icon)
2) Double-Click on "Boot Drive (C)" {"Local Disc(C)"}
3) Menu>-Tools>-Folder Options
4) Click on the "View" tab in the Folder options dialog box that opens
5) Select "Show hidden files, folders and drives"
6) De-select "Hide empty drives...", "Hide extensions.." and "Hide protected operating..." (NO tick in these boxes)
7) Click "Apply to Folders"
8) Click "OK"
9) Assuming you are viewing the root of drive "C" Menu->File>-New>-Folder
10) Name your new folder anything you like e.g. "root"
11) While you are at it, make a new folder at a location for your convenience to store all the files you are going to need. I called
mine "Kindle HD Fire Rooting Files"

Now do your downloads. ADB driver first:
1)Download the adb driver from the link given by PRallday168 in [ROOT] Kindle Fire HD 7" Post #1 in the thread mentioned above:


2) Store this file in your "Kindle HD Fire Rooting Files" folder
3) On Windows 7 Double-click the downloaded "Kindle Fire ADB Drivers.exe"
The driver would not install on Windows XP so proceed to Section 3.5 - "Permission Denied" and other errors during Root process and using Windows XP) first, then return here

Return Here from Section 3.5 if on Windows XP, Java and SDK are now installed.

4) Click on "Install"
5) When the "Device Driver Installation Wizard" pops up click on "Next" in that dialog box
6) When the "Windows Security" dialog appears click on the section "Install this driver software anyway"
7) When completed the Installation Wizard shows a green tick next to the "Amazon.com (WinUSB) Kindle.." in the Driver Name section with Status "Ready to use"
8) Click "Finish"
9) If you have not installed the SDK and Java, another dialog box appears telling you the drivers were not installed properly, and you should do it manually.
10) Ignore this warning and Click "OK" (What do they know)
11) Click "Close" on the original Driver setup box

Now download Bin4ry's rooting tool:
1)Download the rooting tool from the link given by PRallday168 in [ROOT] Kindle Fire HD 7" Post #1:


2) Double-click on the Root_with_Restore_by_Bin4ry_v17.zip downloaded file. This assumes you already have WinRAR, WinZip or similar installed.
3) Open Windows Explorer, and open the folder you created in step 10 earlier. I will assume you named it "root" (You may need to give permission for this to happen)
4) copy all the files from WinRAR to this folder. You should have a folder called "stuff" and 2 files RunMe.bat and RunMe.sh. (The RunMe.sh is for Linux users and can be ignored) For completeness copy these files to your "Kindle HD Fire Rooting Files" folder as well. (I am a bit OCD about keeping the filing system clean and tidy)
5) Check you have everything by opening the "Stuff" folder you just created in C:\root There should be 16 files including adb and adb.exe (again adb with no extension is for Linux)
6) Now the bit not mentioned by the OP, shown to me by azwei and an essential part of the whole process
7) In Windows Explorer navigate (Posh word for click, double-click etc) to C:\Users\<Your name here>. {WinXP C:\Documents and Settings\<Your name here>} My account is Admin so I go to C:\Users\Admin
8) Create a new folder and name it ".android." (note the dots at beginning and end) otherwise you get an error regarding filenames needed. The final dot is removed by Windows. On WinXP this will not work, but the folder is already created for you by installing the SDK and running Eclipse
9) Open your new .android folder
10) Menu>-File>-New>-Text document
11) Name your new text document "adb_usb.txt" (no quotes)
12) open your new document in Notepad (Double-click it!)
13) Type or copy/paste 0x1949
14) Close the file (click save when prompted)
15) Rename this file to adb_usb.ini (ignore the warnings)
An .ini file is an ini(tiation) file and is a text file containing instructions or other data which can be changed by the end user to allow the program that uses it to alter its behaviour. I do not know the inner workings of the adb.exe program, but I guess the 0x1949 gives it instructions on which device it should operate on, or how it should carry out some function differently. I rooted my Sony Xperia Tipo phone with bin4ry setup, with no ini file at all, so it is not always needed.
Also when rooting my Kindle I am not certain whether the whole process was completed already by using this stage alone, but for certainty, lets move on to the next stage

Now download QemuRoot:
1)Download the Qemu Root tool from the link given by PRallday168 in Post #1:


2) Double-click on the QemuRoot_v1.0.zip downloaded file. This assumes you already have WinRAR, WinZip or similar installed.
3) Put this extracted folder in "Kindle HD Fire Rooting Files" folder.
You now have all you need to root your device, but the main purpose of doing this is to add the Google Play store at the very least. So before you rush in to the rooting process, lets get the required files for the play store

Have a look at PRallday168's other post on


From the link in this post download the google play store files. Store them in a new folder called "Apk Files" in your "Kindle HD Fire Rooting Files" (repeated here for your convenience):

https://dl.dropbox.com/u/88552195/Playstore files.zip

If you are Using Windows XP
1) Right-Click on this folder
2) Select "Sharing and Security"
3) Click on "If you underststand the security..." A dialog pops up
4) Select "Just enable File Sharing"
5) Tick "Share this folder..."
6) Name it "APK Files"
7) Tick "Allow network users to change..."
8) Click OK. You have now set up a share on your PC called "APK Files" which you can read and write to. (Useful for storing stuff from your Kindle later)

Almost time to get going, but WAIT...

Section 2 - Prepare your Kindle

Start your Kindle Fire HD

1) Slide the "Unlock" bar on the right. Ignore the annoying advert slider on the left. (You can get rid of that later once you are rooted)
2) Swipe from the top of the tab to open the menu bar
3) Tap "More"
4) Tap "Device"
5) Set "Allow Installation of Applications" to On
6) Tap "Back" arrow to previous page
7) Tap "Security"
8) Set "Enable ADB" to On
9) Tap "Back" twice to home screen
10) Tap "apps" text on the text menu running accross the top
11) Tap "Store>" on top right corner
12) Tap "Search Appstore"
13) type es explorer
14) A number of file explorers appear the one you want is "ES File Explorer" (Free) NOT ES File Explorer Cupcake
15) Install this app and close the store
16) Start ES file Explorer (Apps>-ES File Explorer)
17) By default it opens at /sdcard/. My preference is a list, not icons so tap the "List" button on the right side of the menu bar
18) Tap the Menu icon (Centre bottom of screen), then Settings
19) Tap Root Setings
20) At this stage you will only be able to activate "Up To Root", which allows you to view, but not alter any of the files in root
21) Tap back twice so you are looking at /sdcard again.
22) Tap "Up" on the menu bar and you should see a list of folders beginning with "acct" You are now in "/" which is Root! Unfortunately it is only a sneak peek.

Section 3 - Root your Kindle

You are now ready to root your device. Press back 3x and you should be at your home screen

1) Start Device Manager on your PC (Right-Click Computer>-Properties Click Device Manager on top Left of Control Panel Home)
Plug in your USB cable to both device and PC. Depending on whether you have plugged it in before, and the speed of your PC the discovery may take a while.
Check your kindle for a warning about some operating systems needing extra software. Close this with "OK" if it appears.
Watch the device manager and eventually you should get two {winXP=one} new entries appearing:
a) Portable devices - click on it to reveal "Kindle Fire" (Windows 7 only)
b) Kindle Fire - click on it to reveal "android composite ADB Interface"
As long as these two {one} entries do not have yellow or red warning symbols you should be OK

2) If you are using Windows 7, before moving on, it might be a good idea to copy the Google files across to the Kindle. It can always be done later once rooted. (You will have to on Windows XP)
Double-Click "Computer"
You should now see "Kindle" as a Portable Device"
Double-Click "Kindle"
You should now see "Internal Storage"
Double-Click "Internal Storage"
Double-Click "Download"
Copy the following files you downloaded earlier to this location:
Job Done. Close your Explorer Window(s)

3) Now open a Command Prompt:
Method 1: Click Startbutton>-Programs>-Accessories>-Command Prompt Right-Click on it and select "Run as administrator" (Not necessary on XP unless you are running more than one account, and yours is not administrator status)
Method 2: Click Startbutton>-Run Type in cmd and press Enter. If you do not have the text "This task will be created with administrative privileges" in the Run dialog box, then use method 1 above.

You should now have a black window open displaying some text courtesy of Microsoft and ending with C:\Users\Your account name>. {Win XP C:\Documents and Settings\<Your account name>} Mine is


Type the following in this window:
[HIGH]cd C:\root
Press Enter[/HIGH]If you created a different folder in Section 1 step 10 use that name instead:

[HIGH]cd C:\Your Folder Name[/HIGH]Press Enter

Now type:
Press Enter[/HIGH]You should now get a listing including:
[HIGH]Date Time 10,278 RunMe.bat
Date Time 11,745 RunMe.sh
Date Time <DIR> stuff[/HIGH]Now type:
[HIGH]stuff\adb devices
Press Enter[/HIGH]You should get an output like:
[HIGH]* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached
D025A0A024360KLP device[/HIGH]The number here is probably different to yours, but it means a device has been found.
If you get:
[HIGH]emulator-5554 device[/HIGH]then you are running the BlueStacks android emulator and rooting will not work. Uninstall Bluestacks or use a different PC

It is now safe to start the rooting process
Press Enter
[/HIGH]This runs a bat(ch) file called RunMe, which is a list of DOS commands to carry out instructions.
The text colour changes to green and you are given the following choices:
[HIGH]Device type:
1) Normal
2) Special (for example: Sony Tablet S, Medion Lifetab)

x) unroot

Make a choice:
[/HIGH]Before you continue, check your kindle screen is active and unlocked.
Type 1 and press enter

Look at your kindle screen. At some point you will get a message about restoring data on the kindle. Tap "Restore", on the lower right side of the screen

After more messages appearing on the command prompt window it will re-boot your kindle and wait for it to be re-attached by the Windows drivers. Just be patient and let it do its stuff. The Kindle may run slowly at this stage. Unlock it by sliding the tab when it appears.
Thanks to bottemann:
1) After the reboot following running RunMe.bat, my kindle was extremely slow and wouldn't even finish drawing the screens, just as Delusionalhelp described in post #27. After reading his post, I ran the RunMe.bat again and rebooted again, and voila, it came up working like a charm.

Eventually you will see on your PC:

You can close all open command-prompts now!
After reboot all is done! Have fun!

The first stage is now finished.

If you are on version 7.2.3 Kindle Firmware you are done. You can re-boot your Kindle

If you are not on version 7.2.3 carry out the next stage using QemuRoot for your Kindle Fire.

After re-boot, allow time to get the device connected, (check device manager).
Check it is connected using the same method as before (brief reminder here. see Section 3 for full description):
1) open Command prompt
2) change directory to C:\root
[HIGH]stuff\adb devices
Press Enter[/HIGH]You should get an output like:
[HIGH]* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached
D025A0A024360KLP device[/HIGH]If all is well then navigate to your QemuRoot folder, which you created earlier. Right-Click on RootQuemu.bat and "Run as administrator"
On the command prompt choose 1) root:
[HIGH]type 1
press Enter[/HIGH]after a number of messages asking you to press any key it should re-boot the kindle. Repeat as necessary. Remember to look at the kindle and unlock the screen at the appropriate time. Your device will be rooted after the final reboot is done. You should have SuperUser and access to system files.

Section 3.5 - "Permission Denied" and other errors during Root process and using Windows XP

If you look through the rest of this thread you will discover some stubborn Kindles that appear not to allow you access to the device and return "Permission Denied" errors.
With huge thanks to posts provided by Rollout (see below from post #8 onwards) you may still succeed by using the Android SDK (Software Development Kit)

Before going down this root please check the following have been done correctly:
1) Kindle has been set up to "Allow Installation of Applications"
2) Kindle has been set up to "Allow adb dubugging" (See Section 2 for details)
3) adb_usb.ini has been created on your PC (See section 1 step 7 for details)

All above correct and still no joy? (or you are running Windows XP)
Please proceed:

Download and install JRE (Java Runtime Environment) from

Download Free Java Software

(Minecraft players will already have this on their PC!)
You can also use the JDK (Java Development Kit), but only if you intend to develop your own apps.

Download Android SDK Bundle for Windows:

Android SDK | Android Developers

Click on Download Icon
Accept License Agreement
Click 32bit or 64bit Windows. Most Windows 7 users will be on 64 bit. Most XP users will be 32 bit. Various ways to check, but a quick one is to look in C:\ and see if there is a folder called "C:\Program Files (x86)". If there is you are using 64bit. If not you are using 32bit
Save File (zip Format - 399MB)
UnPack with WinRAR,Winzip or whatever you use
Copy the whole "adt-bundle-windows-x86_64" (WinXP "adt-bundle-windows-x86") folder to C:\Program Files\
Follow setup instructions:

Setting Up the ADT Bundle | Android Developers

If you are running Windows XP, you have installed Java and the SDK you should now return back to Section 1 Step 4 and try the normal Bin4ry rooting process first. If that fails then continue

Continue from here if on Windows 7 or XP with "permission denied" errors

Once setup copy the contents of Bin4ry's rooting tool into C:\Program Files\adt-bundle-windows-x86_64\sdk\platform-tools\ (WinXP -C:\Program Files\adt-bundle-windows-x86\sdk\platform-tools\)
That is both RunMe.bat and the "stuff" folder.
You are now going to replace the RunMe.bat file with a modified version that uses the adb.exe file included in the SDK kit, instead of the one in Bin4ry's stuff folder.
Method 1:
1) Go to post #20 in this thread and click on the link at the top of the code "View Plain". This will open a new window with all the lines of code but no line numbers.
2) Copy the whole thing into Notepad
3) File>-Save As RunMe.txt, (preferably in the C:\Program Files\adt-bundle-windows-x86_64\sdk\platform-tools\ folder.)
4) Rename the existing RunMe.bat file to RunMe.bak (Bin4ry's original script)
5) Rename RunMe.txt to RunMe.bat

Method 2:
Download this file:

View attachment RunMe.txt

I have attached RunMe.txt here as .bat files are not permitted. Proceed from step 3 above

1) Open a command prompt as administrator
2) Type
[HIGH]cd C:\Program Files\adt-bundle-windows-x86_64\sdk\platform-tools\
Section 4 - Setup your rooted Kindle Fire for Google Play

If You have not already copied the Google files to your Kindle, go up to Section 3, #2 and do it now (Connect via USB first!)
If you are running WindowsXP, I do not see an obvious connection to your Kindle that shows up as a removeable drive. There are a number of ways to transfer files but the easiest is to use ES File Explorer
1) On your Kindle tap "apps", then "ES File Explorer" (You DID install this earlier...)
2) Tap the Menu icon
3) Tap Settings
4) Tap Root Settings (Near the end of the list, you may need to scroll down)
5) Tap Root Explorer on the check box
6) With luck a message regarding SuperUser will pop up
7) Tap "Grant"
8) Ensure all the sections here have a green tick by selecting in turn:
Root Explorer
Up To Root
Mount File System
Backup System App
(Un)install apk automatically
9) Tap back button twice (to /sdcard)
10) For Windows 7 users who have already copied the GooglePlay .apk files GoTo to step 31

(Windows XP and cant see my Kindle as a removeable device)
11) Start ES File Manager
12) Tap The word "Local" in the top left corner of the screen
13) On the dialog tap "LAN"
14) Tap Menu
15) Tap New
16) Tap Server
17) Fill in your PC's IP address in the "Server" field. I have my main PC set at a fixed IP of
18) If you do not know the IP open a command prompt and type ipconfig /all and press Enter. It should be listed somewhere in all the output text
19) Fill in your username and password that you use to access your PC at boot-up, or else tap Anonymous
20) Fill in a name to display the share as when viewing it on your device. Mine is "HomeServer"
21) Tap OK. With luck a new icon appears with a green planet earth sitting on a laptop with the name you just typed. If it is not connected check and edit the LAN settings
22) Tap your new connection. The address bar will show smb:// (or your IP address). This confirms you are using the Linux Samba network protocol to connect to your PC. (I am using Win7 Enterprise, but I am fairly sure other versions support Samba natively)
23) If you have previously set up any shares such as "APK Files" (see Section 1 -If you are Using Windows XP-) on your PC they will be listed. I am not certain which shares are enabled by default, but you should get at least "Users" if you used your username and password to connect. Once established, copy the files from your PC to the Downloads folder on your Kindle:
24) Tap "APK Files" (The share you set up earlier..?)
25) Tap the menu icon "Select" (Second one along after "Favourites")
26) Tap GoogleServicesFramework.apk, GPlay3.8.17.apk and Vending.apk, The text should go green to confirm they have been selected.
27) Tap "Copy" on the menu icon (Third one along)
28) Tap "Local" on the top menu bar (Local|LAN|FTP|Net)
29) Ensure you are in /sdcard/Downloads
30) Tap Paste (5th icon along) GoTO step 32

Continue from here if files already in /sdcard/Downloads (Win 7)
31)Tap "Download" folder. This should reveal the 3 files you copied here earlier from your PC
32) Tap "GoogleServicesFramework.apk" This should install it from here, with a confirmation message.
33) Tap the menu icon "Select" (Second one along after "Favourites")
34) Tap Vending.apk The text should go green to confirm it has been selected
35) Tap "Copy" on the menu icon (Third one along)
36) Tap "Up" icon (4th one along) twice. This should take you to / (root)
37) Scroll down and tap "System"
38) Tap "app" You should now be in /system/app directory
39) Tap "Paste" menu icon(5th one along) this should paste the file into this folder. If you are not rooted, or you have not set the "Mount File System" settings earlier then it will fail
40) Tap Back arrow and quit ES file explorer

Before you go any further re-boot your kindle (Power off and power back on Kindle!)

1) Open ES File explorer and navigate to /system/apps
2) Take care here to use a long press. You want to open the properties of this file, not install it:
Long press on the vending.apk and select properties>-change permissions and make sure the following are checked:
User: read, write
Group: read
Other: read
3) now tap on the vending.apk and press ok to replace and install.
4) Tap back until you exit ES File explorer
5) Tap apps
6) Tap "Market" and sign in to your Google account.
Thanks to bottemann:
Also I found that I couldn't reach the google server to log in, again just as Delusionalhelp described in post #28. After a half dozen tries, I finally logged in successfully, and then proceeded with installation of google play.
7) Start ES Explorer
8) Navigate to /sdcard/download
9) Tap and install the Gplay3.8.17.apk and wait for the confirmation message
10) Restart the Kindle once more.
11) GooglePlay should now be installed. The world is your oyster, as they say
12) Enjoy


After going through all this trouble, you do not want Amazon to update your Kindle firmware and destroy all your hard work. Refer to this Thread (Post#2):

To prevent an automatic update.
Wow, thanks for this amazing walkthrough.

I still need to pick your brains!!

I'm getting this info from the CMD window

* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached

But there isnt any numbers below. I have two entries on device manager and it shows in windows explorer as a drive

If I carry on and run RunMe and select option 1 it just seems to hang on "Checking if I should run in normal mode or special Sony Mode. Please connect your device with USB-Debugging enabled now"

Any ideas?
Upvote 0
Great post Inksaver. What would we do without people like you. Worked a treat. A couple of questions I don't know if you can help?

A lot of the apps on the carousel appear blurry. Is there anything that can be done about this.

Some of the apps are still incompatible like instagram and tvcatchup. How do you get these on the device?

Keep up the good work!
Upvote 0
The apps on the caousel are blurry because they are the icons you see when you tap apps and they are listed, but magnified to a much bigger size. Their resolution is too low. Probably not much you can do about it.

Incompatible apps can be copied from another device you own using appmonster. If you do not own another device create one using BlueStacks on your PC

I will do another tutorial tomorrow on this subject and the way I got Carbs & Cals working on my Sony Xperia Tipo phone, although it is incompatible if you try and install it directly from the app store
Upvote 0
I'm getting this info from the CMD window

List of devices attached

But there isnt any numbers below. I have two entries on device manager and it shows in windows explorer as a drive

If I carry on and run RunMe and select option 1 it just seems to hang on "Checking if I should run in normal mode or special Sony Mode. Please connect your device with USB-Debugging enabled now"

what should i do ??

ps: the first time i tried i got
* daemon not running. starting it now on port 5037 *
* daemon started successfully *

but now i only get
List of devices attached

plz help me
Upvote 0
By far the best set of directions I have seen, thank you for taking the time to do it.

I do have a question. I am still getting permission errors in both the runme.bat, and the rootqemu. It says permission denied to creating any of the files/folders, such as coping stuff/su over to /data/local/tmp/./su also when coping superuser.

any ideas? Been at this for a while

edit: I am using win7 , and using admin for my cmd console. It is not working...
one example, /system/bin/sh: cannot create /data/local.prop: Permission denied.
It does find it and give me shell access in adb though.
Upvote 0

Great you got it done. In your original post you could not get any devices listed. Had I seen that post before you posted again I would have asked the same question as I did for Danman07 in post#3.
Could you post what improvisation you had to make in order to get it to work?


I am very new to Android as an operating system, so I will not pretend to be any sort of expert at it but I have a couple of ideas. If you drop RunMe.bat into Notepad you can see the commands used. In this excerpt:

[HIGH]echo Pushing busybox....
stuff\adb.exe push stuff/busybox /data/local/tmp/.[/HIGH]

Line 1 echo Pushing busybox.... This causes (echos) the text "Pushing busybox...." to appear in the CMD window.

Line 2 stuff\adb.exe push stuff/busybox /data/local/tmp/. The backslash between stuff and adb.exe shows you this is a DOS command meaning Run adb.exe, which is located in the folder "stuff".

The "push" command is a parameter passed to the program adb.exe telling it to "push" or "send" or "Copy" the file called busybox which is located in the folder stuff. This time there is a forward slash between stuff and busybox, because the program adb.exe is expecting paths to be described in the Unix/Linux/just about every other OS format except Microsoft.

The final part /data/local/tmp/. is telling adb.exe where it should copy busybox to. This is a path on the Kindle, NOT on your PC. If you are getting "Permission denied" errors, it could be the permission is denied on the Kindle, NOT your PC and that adb.exe is returning an error message back to DOS, which is displayed on the console.

Could you check you have set permissions in your Kindle as in Section 2 of my original post?
  • Like
Reactions: DGS75028
Upvote 0
This is the problem I had originally.
Make sure you have created the adb_usb.ini file in c:\Users\Your Acount Name\.android and it contains the single line of text 0x1949

See section 1 in the instructions for further details


When I changed it from a txt to ini the first time for some reason it was seeing it as a .txt.ini file. When I changed it properly it worked

Thank you so much for your help.
Upvote 0

I also assumed that it is permission denied on the side of the kindle. I have quite a computer background, including some linux server builds and maintenance.

I get the path issues, and just tried some experiments with no success, but will continue. I did not think of that as so many have had those two scripts just work for them in windows 7...

By the time I saw your post yesterday I had tried many variants to it already, to no avail.

I followed all your instructions step by step. I just went back and double checked #2, and yes adb is on, allow installation of other apps is on, es is installed and working.

It still gives the permission denied, even if I try to do it from a cmd window (as admin), manually instead of using the script.

I am at a loss...
Upvote 0
Nice job on this really detailed guide.! Ive been busy with the holidays and family and all and havent been able to get on here and help. Thank you Inksaver for helping out. On another note the 7.2.3 updated version can now be rooted with only Bin4ry's tool. So you dont have to use QemuRoot. Also i cant stress this enough but since others are working around the locked bootloader, we are very prone to getting our KFHD's Bricked like me. so head on over to http://forum.xda-developers.com/showthread.php?t=1392693 and make yourself a factory cable or simply buy one from SkOrPn's 8th post. i bought mine and it has saved my KFHD twice! he has guides on what is fastboot and how to use his cable.
Upvote 0
Thanks PRallday168

It was your guide I followed to get my Kindle rooted, but I thought it might be useful to take the time to give a really detailed guide for those not so familiar with the whole process.
I used to be a moderater on one of the VB forums, and was always helping people out with their projects, which I enjoyed very much.

Thanks for the advice on the factory cable. Time to get out my magnifying loupes and sharpen the soldering iron. Looks like a similar job to soldering a wire on to the cut leg on an IC in the Wii to mod it after Nintendo clipped them off!


Can't think of any sensible reason here.
A couple of things I might try in your situation, first try a different PC and second try a Factory Reset on the Kindle?
Upvote 0
Thank you for the advice.
I got it to write after the factory default reset. Runme.bat ran, and did not give the permission denied after, however when it came back up it said mount: permission denied, are you root?
It did successfully push the files before the initial reboot where you hit restore.
After a reboot, or even two, it does not give me root. Tried 10 times now.
It is the version 7.2.3 , so that should be it. It is not working though.

any further suggestions?

EDIT Success!!!

I found that the Bin4ry Runme has it's own adb in the stuff folder, and relies on running from it. This version does not run on all systems. What I did was installed the android SDK, copied the RunMe.bat and the "stuff" folder into the adt-bundle folder in the sdk/platform-tools/ . I then modified the RunMe in notepad, and removed the stuff\ from in front of all of the adb.exe references. I then opened a cmd prompt, navigated to that folder, ran the Runme, and it worked like a champ.
Upvote 0
Rollout that is great news! Well done

I am curious about the version of adb.exe in Bin4ry's root package not working on all systems. If I Right-Click>- properties I get:
Size 162,186
Size on disc 163,840
Modified 13 Jan 2012 21:50:48

Could you confirm the version in the SDK is different?

Also, instead of modifying RunMe.bat, would it have worked if you had replaced the adb.exe in the \stuff folder with the version of adb.exe you downloaded with the SDK?

I am thinking about other forum users getting a similar error to yourself, and if a simple substitution worked then that could be added to the tutorial.
Upvote 0
159kb size for the Bin4ry version. 796kb for the SDK version.
I did not want to move adb out of the directory with the other SDK tools. I suppose I could have done a symbolic link or something, but it was day two at 3am... It might have worked to copy it over to that folder, but I did not give it a go.

It was easier to just modify the RunMe.bat .

It is funny that with the version 7.2.3 people are having problems all over, and there is not really a solution anywhere on the net. I posted this on a few other forums as well. Hopefully I stumbled onto a solution for all.

Perhaps just putting a modified RunMe.bat for download?
Upvote 0
I have downloaded the SDK, put the entire package into C:\Program Files\adt-bundle-windows-x86_64\ and installed Eclipse, copied the stuff folder to the adt-bundle-windows-x86_64\sdk\platform-tools\ along with the RunMe.bat.

I have modified RunMe.bat to remind users it should only be run from the SDK folder and should have \stuff added to the same folder. I have modified all stuff\adb references to adb.The final file looks like this:

[HIGH]@echo off
echo ======================================================================
echo = This script will root your Android phone with adb restore function =
echo = Script by Bin4ry (thanks to Goroh_kun and tkymgr for the idea) =
echo = Idea for Tablet S from Fi01_IS01 =
echo = (22.11.2012) v17 =
echo = Script modified to run from Install Location/sdk/platform-tools =
echo = Make sure you have the stuff folder copied here as well! =
echo ======================================================================
set nxt=0
set ric=0
echo Device type:
echo 1) Normal
echo 2) Special (for example: Sony Tablet S, Medion Lifetab)
echo x) Unroot
set /p type=Make a choice:
if %type% == 1 GOTO TEST
if %type% == 2 GOTO TABSMENU
if %type% == x GOTO UNROOT
echo Please Enter a valid number (1 to x)

echo Checking if i should run in Normal Mode or special Sony Mode
echo Please connect your device with USB-Debugging enabled now
adb.exe wait-for-device
adb.exe pull /system/app/Backup-Restore.apk . > NUL
adb.exe pull /system/bin/ric . > NUL
if EXIST ric (set ric=1) else (echo .)
if EXIST Backup-Restore.apk (GOTO XPS) else (echo .)

set /p unr=Really (y/n) ?
IF %unr% == n GOTO CHOICE
adb.exe push stuff\busybox /data/local/tmp/busybox
adb.exe shell "chmod 755 /data/local/tmp/busybox"
adb.exe shell "su -c '/data/local/tmp/busybox mount -o remount,rw /system'"
adb.exe shell "su -c 'rm /system/bin/su'"
adb.exe shell "su -c 'rm /system/app/Superuser.apk'"

echo Special mode:
echo 1) Root
echo 2) Rollback
set /p tabtype=Make a choice:
if %tabtype% == 1 GOTO TABS
if %tabtype% == 2 GOTO TABS_RB

echo Tablet S mode enabled!

echo Found Sony Backup-Restore.apk
echo LT26,LT22 etc. mode enabled!
del Backup-Restore.apk
if %ric% == 1 (del ric) else (echo .)
set NXT=1

echo Tablet S Roll Back
echo Please connect device with ADB-Debugging enabled now....
adb.exe wait-for-device
FOR /F "tokens=1 delims=" %%A in ('adb.exe shell "if [ -d /data/app- ]; then echo 1 ; else echo 0 ; fi"') do SET tabs_app=%%A
if %tabs_app% == 1 GOTO TABS_RB_1
if %tabs_app% == 0 GOTO TABS_RB_2

adb.exe shell "rm -r /data/data/com.android.settings/a/*"
adb.exe restore stuff/tabletS.ab
echo Please look at your device and click "Restore my data"
adb.exe shell "while [ ! -d /data/data/com.android.settings/a/file99 ] ; do echo 1; done" > NUL
echo 1st RESTORE OK, hit ENTER to continue.
adb.exe shell "rm -r /data/data/com.android.settings/a"
adb.exe restore stuff/tabletS.ab
echo Please look at your device and click "Restore my data"
adb.exe shell "while : ; do ln -s /data /data/data/com.android.settings/a/file99; [ -f /data/file99 ] && exit; done" > NUL
adb.exe shell "rm -r /data/file99"
echo Achieved! hit ENTER to continue.
adb.exe shell "mv /data/system /data/system3"
adb.exe shell "mv /data/system- /data/system"
adb.exe shell "mv /data/app /data/app3"
adb.exe shell "mv /data/app- /data/app"
echo "Roll back compelted."

echo "Roll back failed. /data/app- not found."

echo Normal Mode enabled!
if %ric% == 1 (del ric) else (echo .)

adb.exe wait-for-device
IF %type% == 2 GOTO TABTRICK
echo Pushing busybox....
adb.exe push stuff/busybox /data/local/tmp/.
echo Pushing su binary ....
adb.exe push stuff/su /data/local/tmp/.
echo Pushing Superuser app
adb.exe push stuff/Superuser.apk /data/local/tmp/.
echo Making busybox runable ...
adb.exe shell chmod 755 /data/local/tmp/busybox
if %ric% == 1 (adb.exe push stuff/ric /data/local/tmp/ric) else (echo .)
adb.exe restore stuff/fakebackup.ab
echo Please look at your device and click RESTORE!
echo If all is successful i will tell you, if not this shell will run forever.
echo Running ...
adb.exe shell "while ! ln -s /data/local.prop /data/data/com.android.settings/a/file99; do :; done" > NUL
echo Successful, going to reboot your device in 10 seconds!
ping -n 10 > NUL
adb.exe reboot
echo Waiting for device to show up again....
ping -n 10 > NUL
adb.exe wait-for-device

adb.exe install -s stuff/Term.apk
adb.exe push stuff/busybox /data/local/tmp/.
adb.exe push stuff/su /data/local/tmp/.
adb.exe push stuff/Superuser.apk /data/local/tmp/.
adb.exe push stuff/rootkittablet.tar.gz /data/local/tmp/rootkittablet.tar.gz
adb.exe shell "chmod 755 /data/local/tmp/busybox"
adb.exe shell "/data/local/tmp/busybox tar -C /data/local/tmp -x -v -f /data/local/tmp/rootkittablet.tar.gz"
adb.exe shell "chmod 644 /data/local/tmp/VpnFaker.apk"
adb.exe shell "touch -t 1346025600 /data/local/tmp/VpnFaker.apk"
adb.exe shell "chmod 755 /data/local/tmp/_su"
adb.exe shell "chmod 755 /data/local/tmp/su"
adb.exe shell "chmod 755 /data/local/tmp/onload.sh"
adb.exe shell "chmod 755 /data/local/tmp/onload2.sh"
adb.exe shell "rm -r /data/data/com.android.settings/a/*"
adb.exe restore stuff/tabletS.ab
echo Please look at your device and click "Restore my data"
adb.exe shell "while [ ! -d /data/data/com.android.settings/a/file99 ] ; do echo 1; done" > NUL
ping -n 3 > NUL
echo 1st RESTORE OK, hit ENTER to continue.
adb.exe shell "rm -r /data/data/com.android.settings/a"
adb.exe restore stuff/tabletS.ab
echo Please look at your device and click "Restore my data"
adb.exe shell "while : ; do ln -s /data /data/data/com.android.settings/a/file99; [ -f /data/file99 ] && exit; done" > NUL
adb.exe shell "rm -r /data/file99"
ping -n 3 > NUL
echo Achieved! hit ENTER to continue.
adb.exe shell "/data/local/tmp/busybox cp -r /data/system /data/system2"
adb.exe shell "/data/local/tmp/busybox find /data/system2 -type f -exec chmod 666 {} \;"
adb.exe shell "/data/local/tmp/busybox find /data/system2 -type d -exec chmod 777 {} \;"
adb.exe shell "mv /data/system /data/system-"
adb.exe shell "mv /data/system2 /data/system"
adb.exe shell "mv /data/app /data/app-"
adb.exe shell "mkdir /data/app"
adb.exe shell "mv /data/local/tmp/VpnFaker.apk /data/app"
adb.exe shell "/data/local/tmp/busybox sed -f /data/local/tmp/packages.xml.sed /data/system-/packages.xml > /data/system/packages.xml"
adb.exe shell "sync; sync; sync"
echo Need to reboot now!
adb.exe reboot
ping -n 3 > NUL
echo Waiting for device to come up again....
adb.exe wait-for-device
echo Unlock your device, a Terminal will show now, type this 2 lines, after each line press ENTER
echo /data/local/tmp/onload.sh
echo /data/local/tmp/onload2.sh
echo after this is done press a key here in this shell to continue!
echo If the shell on your device does not show please re-start the process!
adb.exe shell "am start -n com.android.vpndialogs/.Term"

adb.exe push stuff/script1.sh /data/local/tmp/.
adb.exe shell "chmod 755 /data/local/tmp/script1.sh"
adb.exe shell "/data/local/tmp/script1.sh"
echo Almost complete! Reboot and cleanup.
adb.exe reboot
ping -n 3 > NUL
echo Waiting for device to come up again....
adb.exe wait-for-device
adb.exe shell "su -c 'rm -r /data/app2'"
adb.exe shell "su -c 'rm -r /data/system2'"
adb.exe shell "su -c 'rm -r /data/local/tmp/*'"

set %NXT%=0
echo Pushing fake Backup
adb.exe push stuff\RootMe.tar /data/local/tmp/RootMe.tar
adb.exe shell "mkdir /mnt/sdcard/.semc-fullbackup > /dev/null 2>&1"
echo Extracting fakebackup on device ...
adb.exe shell "cd /mnt/sdcard/.semc-fullbackup/; /data/local/tmp/busybox tar xf /data/local/tmp/RootMe.tar"
echo Watch now your device. Select the backup named RootMe and restore it!
adb.exe shell "am start com.sonyericsson.vendor.backuprestore/.ui.BackupActivity"
echo If all is successful i will tell you, if not this shell will run forever.
echo Running ......
adb.exe shell "while ! ln -s /data/local.prop /data/data/com.android.settings/a/file99; do :; done" > NUL
echo Good, it worked! Now we are rebooting soon, please be patient!
ping -n 3 > NUL
adb.exe shell "rm -r /mnt/sdcard/.semc-fullbackup/RootMe"
adb.exe reboot
ping -n 10 > NUL
echo Waiting for device to come up again....
adb.exe wait-for-device

echo Going to copy files to it's place
adb.exe shell "/data/local/tmp/busybox mount -o remount,rw /system && /data/local/tmp/busybox mv /data/local/tmp/su /system/xbin/su && /data/local/tmp/busybox mv /data/local/tmp/Superuser.apk /system/app/Superuser.apk && /data/local/tmp/busybox cp /data/local/tmp/busybox /system/xbin/busybox && chown 0.0 /system/xbin/su && chmod 06755 /system/xbin/su && chmod 655 /system/app/Superuser.apk && chmod 755 /system/xbin/busybox && rm /data/local.prop && reboot"

echo Going to copy files to it's place
adb.exe shell "/data/local/tmp/busybox mount -o remount,rw /system && /data/local/tmp/busybox mv /data/local/tmp/ric /system/bin/ric && chmod 755 /system/bin/ric && /data/local/tmp/busybox mv /data/local/tmp/su /system/xbin/su && /data/local/tmp/busybox mv /data/local/tmp/Superuser.apk /system/app/Superuser.apk && /data/local/tmp/busybox cp /data/local/tmp/busybox /system/xbin/busybox && chown 0.0 /system/xbin/su && chmod 06755 /system/xbin/su && chmod 655 /system/app/Superuser.apk && chmod 755 /system/xbin/busybox && rm /data/local.prop && reboot"

echo You can close all open command-prompts now!
echo After reboot all is done! Have fun!
echo Bin4ry
pause[/HIGH]Could you check this is similar to your modified file, and if so it could be added as an attachment here for download (presumably only in text format), along with instructions for installing the SDK and running it from there as you have already done
Upvote 0

Well done.

It looks like it worked well for you. If you read this whole thread you will see that Rollout has had some issues, and he and I are trying to work out why, and what can be done about it.

Could you let me know the frimware version of your Kindle, and the Windows version you are using? This might help us to narrow down the problems
Upvote 0
That looks like the ticket! Hopefully it saves some people a great deal of time...:)
From what I have read the problems exist on the version 7.2.3, and there are even some rumors out there that it can not be rooted unless it was prior to upgrading to that version. This came out of the box with that version. I do not like no as an answer so I kept at it.

Great work on the documentation.

By the way, doing it this way I did not have to do the ini fie either... Not sure if that's going to be for everyone or not.
  • Like
Reactions: Inksaver
Upvote 0
The strange thing is, when I started my Kindle, and set it up for the first time, within minutes the screen was showing an update in progress, which I left running as I knew no better, and after a restart it was then on 7.2.3, before I had even had a chance to play with it.

When trying to root it I was unable to get it recognised by adb until I added the .ini file. After that it all went well.
I have asked recent posters what version they have, and as you can see, overall most seem to be succeeding.

One possible difference, I am in the UK. Could it be there are slight variations in the firmware depending which country you purchase it from?
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.