• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

In TWRP recovery how to fix unable to mount data internal/external/otg USB storage 0mb in twrp


Well-Known Member
Jan 10, 2020
I have a mobile lyf water 8 ls 5015 with Android 6.1 marshmellow vendor updated I want to take NAND backup before rooting through loading twrp recovery in fast boot mode (fastboot recovery twrp.img) .

I tried with 3 twrp recovery Images listed below one twrp 2.8.4 recovery image original from twrp website and other two from XDA. Links given below but all giving same error of mount "0mb" storage in backup menu as not able to select any the destination drive for saving NANDROID backup system.img boot.Img data.img to store.

twrp backup menu destination storage 0 mb error


1.Twrp recovery 2.8.4 image original twrp website image


2. Twrp recovery image for lyf water 8 Android 5.1 lolipop from XDA


3. Twrp 3.1 recovery image modified for lyf water 8 Android 6.1 marshmallow from XDA

after searching googling found that it's been encrypted and have to decrypt .The solution are as below with links

1. Solution Twrp mount Zero mb error screen lock pin solutions in appuals link

Above link says

The first thing to try is if somehow your internal storage became encrypted when using a legacy screen lock method. Go to your Android
device’s Settings > Security > Screen Lock, and change your screen
lock method to either Pass or Pin. Create a new one. Reboot into TWRP,
and it should ask for a password – enter the pass or pin you just
created. TWRP will attempt to decrypt your device’s internal storage,
and if it succeeds, you should not have further issues. However, if
this does not solve your issue of “unable to mount data, internal
storage 0mb”, continue with the rest of this guide. Reboot your device
into TWRP again. Navigate to Wipe > Advance Wipe > Data, and choose
Repair or Change File System. Press Repair File System to see if this
fixes the issue. If not, continue. Press Change File System, choose
Ext2, and swipe to confirm. Now switch back to Ext4 and swipe to
confirm. Go back to TWRP main menu, then the Mount menu, and check if
your partitions can be mounted now. If you are still unable to mount
your partitions, you need to repair Internal partition, which will
most likely wipe your internal storage.

As suggested The password pin I put in screen lock is never asked if I boot the two recovery image k. Fast boot mode (fastboot recovery trwrp.img so solution didn't worked

2. Solution for Twrp recovery mount 0mb fix solution to wipe repair the file syste ext2 the. Extra in XDA


As above link says solution steps
This will wipe/format your Data partion and your data will be reset.


1) Reboot your device into TWRP Recovery.

2) Go to Wipe menu.

3) Go to Advance Wipe.

4) Select Data and go to Repair or Change File System.

5) Click Repair File System. (If not fix, go to step number 6)

6) Go to Change File System.

7) Select Ext2 and swipe to confirm.

8) Now change back to Ext4 and swipe to confirm.

9) Now go back and check if your partions can be mount or not from
Mount menu.

10) If not fix, repair your Internal partition. (This may wipe your
Internal storage).
OR Unlock your bootloader again.

As per wipe option I tried to repair the file system of /data or. External HDD card it gave following errors . As in. Screenshot below

twrp recovery wipe menu repair file system errors screenshot



Any solution for solving the two Mounting problem decrypting or converting file system any solution any expert can help
Last edited:


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.