• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root [International] 64 gb micro sd class 10 + samsung galaxy s4


Android Expert
Aug 19, 2012
Bombay India
hey guys i am currently using the s4 with a 64 gb sandisk card, i had used the same card in my s3 also and from the time i had the s3 to now when titanium backup auto runs(schedule) my memory card dies. I have to restart the phone and it shows up after that properly. I have since then got the card replaced from sandisk and unfortunately still have the same issue. I was just wondering how many of you guys are using the sandisk 64gb class 10 card and which format have u formatted it in? I actually would like to format it in ntfs or fat32 as opposed to ExFat but im not sure my phone would read it. I read up on xda that the memory card is partitioned with an extra 16mb of space and u can format it to remove the space using diskpart which i tried then formatted the card in fat32 copied all the data back only to find that the phone does not read the card it says card damaged. So reformatted it in the phone and its back to exfat so i dunno what to do. I am travelling next week to london and cant afford to send it for replacement now and dont want it die when im there. Any ideas?

Also on a totally unrelated note my touch screen has started acting weird today, sometimes when i unlock the screen(power button) i cant do anything i cant unlock the pattern lock or do anything on the screen i have to restart the phone completely although when restarting the phone i am able to press the restart button so i dunno what the issue could be. I am running omega rom if that makes a difference.
ya im sure it does not need a class 10 but the sandisk 64 gb was available only in class 10 i was using a 32gb class 4 in my s3 before i bought the 64gb and it worked great. Im guessing exfat and exfat32 are not the same. Im waiting for the auto run of TB in about 1hr 45 mins and see if it fails again then will format it again in exfat32 currently its in exfat.
  • Like
Reactions: ironass
Upvote 0
windows cant format the 64gb drive in fat32. it can only do it in ntfs or Exfat. I have found a tool that lets me format it in fat32 and have formatted it and going to try it now just copying all the data back. Have a look at my attachment.


  • format options.png
    format options.png
    8.4 KB · Views: 84
Upvote 0
OK silentwitness... I am losing the plot! :rolleyes:

I know I have formatted my Class 10, 64GB, SD card on the computer via USB reader. Unfortunately, or fortunately, I have 2 desktops and 2 laptops in home and office and all have different uses and prog's on.

I've been scouring through them and the study PC has Mini Tool Partition Wizard on it which sounds familiar. I just Googled it and found the link...

MiniTool Partition Wizard Home Edition

and instructions...


It looks familiar... but there again, so did SD Formatter! I think I've only ever used it the once to change to ExFAT32 to solve a problem. Will continue scouring.
  • Like
Reactions: silentwitness
Upvote 0
i have formatted it in Fat32 and now when i try to run it in automated mode its running right now its reached 10% and after that get the same error but my memory card has not been disconnected like it normally does when it was in ExFat format. I get an error "batch backup interrupted insufficient free storage space". I checked the batch backup path and its set correctly to my external memory card. The strange thing is when i try to run the same backup manually it runs perfectly without any issue. Are you sure that your card format is ExFat32? can you connect it to a pc and check properties and confirm please.
Upvote 0
Will do when I get it back. It's in Kerala, India, at the moment with one of the stable girls. Loaded with music and videos. Meanwhile, I''m scraping by on a 32GB which is definitely FAT32. I had the same problem as you and I think I found the solution on xda.... but where on xda, I don't remember.

You've got me doubting myself now! :dontknow:
Upvote 0
ure from india? I have formatted the 64gb is fat32 now going to try it out for a couple of days and see have contacted sandisk again regarding the issue. Going to try out an app called "h2testw_1.4" which tests the memory card to see if its working properly or not it basically writes the whole capacity of the card and then reads it back and checks if its working correctly or not. Will search through XDA myself and see if i can find anything dont really like posting questions there as people are tooo rude as compared to here were people are much nicer. Im sorry if i got you doubting yourself :(
Upvote 0
No, I'm not. She's gone out there for a holiday with friends and staying in a rented villa I believe.

I did tell you that SD cards were not my specialist subject.

I remember trying a few things to get it to work. Will scour other computers to see what else I have.

I know exactly what you mean about xda... swimming with sharks!

Need to lie down with an aspirin sandwich now! ;)

I'm starting to doubt my own sanity.
Upvote 0
ohh well it worked good for a few days and now its giving more problems than before it now randomly deleted 20GB of data from the card and the rest of the folders have a funny U symbol in front of them. I called sandisk who tell me my phone is not supported hence i am facing the issue. They now say the issue is wth samsung and not with sandisk and i should replace my phone.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.