• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root [International] Error After Error, Flashing ROM's - GT-I9506


Apr 4, 2014
So my story begins about 3 days ago when I wanted to root my Galaxy, I managed to do so and used CWM recovery.

I then decided that I wanted a custom ROM so I made a backup of my current, stock ROM and went on to install a new ROM, I forget which. Unfortunately, something went wrong and I soft bricked the device.

I spent the next 2 days finding a ROM that I could flash to get things back in order, thankfully I found a stock ROM on some website which worked though it kept popping up with "Unfortunately, Samsung Keyboard has stopped working".

So I went on to install Cyanogen Mod 11 and a GAPPS file onto my device which is what I was after from the beginning, but I wanted to go back to my stock ROM (the backup).

Upon restoring the stock ROM I was presented with 2 errors, the first being a error message that "Unfortunately, the process com.google.process.gapps has stopped" and some Knox message that stopped me from turning on WiFi
in saying
I've downloaded the ROM from SamMobile however, when I try to flash it, it fails and Odin says "complete(Write) operation failed. and the phone says "ext4 image invalid".

I tried to move past it and installed the CWM recovery and selected factory reset and someone the phone started up but kept bringing up an error message of "Unfortunately, Samsung Keyboard has stopped working".

Upvote 0
I thought the error I had was because the ROM I was downloading was classified as a Vodafone ROM.

Today I downloaded a plain one without any carrier funny business and was left with the exact same error and I found that I couldn't boot my phone into recovery or download mode until I messed around a bit clicking the right buttons in the right way.

I'm back on track now but am still running the CyanogenMod, I wan't to go back to stock android but it seems that isn't going to happen unless someone can help me.

Do I need a pit file or something? Do I need other files other than just the PDA?
Upvote 0
I had a similar-ish problem (couldn't install stock ROM, Wi-Fi wouldn't work). sntaylor suggested to me installing a custom ROM and it worked a treat. If you can find a i9506 DjeMBeY ROM I'd suggest that. If not, there are other ROMs that are basically identical to stock ROMs, often with extra cool features and bloatware taken out. I think there are themes for CM to make it look like the stock rom too if that's any help to you.

I wouldn't mess with .PIT files until you've properly researched it. AFAIK they can potentially brick the phone
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.