• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root [International] (Fixed) problems with internet solved!!


Apr 25, 2013
Hello guys, I decided to flash my second ROM called JellyBeer latest version on my Galaxy S3, my first ROM which I flashed was SuperNexus Build 3 (with no success)
So what's the problems? The biggest problem on these both ROMS was that I couldn't connect to the internet (even if signal was good,I was registered to the network,enabled 3G, and of course it was shown on my signal icon), ok, on the JellyBeer I could connect to the internet only with Opera Mini strange isn't it? Even tried to set up my internet settings again but no luck even if I did all Full wiped+data wipes+dalvik wipe.
Other problem which happened to me only on Jellybeer(based on Android 4.2.2) was Gapps (latest version based on Android 4.2.2) stopped working errors I tried all possible methods which I found on the internet but no luck. Of course I loved this ROM it was very smooth but it's gave me more headache than more satisfaction of it.
I don't know ir it's me such a noob that I can't normally use ROM without problems (like others does) ir it's ROMS problems.
So how's your experiences with the custom ROMS? And maybe anyone know the solution to the network problems on custom ROMS?
BTW when I was bavk to stock ROM all network problems gone.
Im clueless sorry :thinking:
If the 3g or H icon was there, the internet should work. Did things like email work? I really dont understand why only Opera Mini would work.
Sorry i hope someone else is more help :beer:
Yes, E-mail worked too but my other almost all apps didn't want to connect to the internet and even I didn't got error that no internet connection or something like that, just that adress bar on top couldn't finish to load, it's just shown me that loading,but it's couldn't to complete loading,so I just got the error that it's loading too long and time is over (I forgot that exactly error) And for example on Firefox mobile it's shown me IP error (I forgot what was written there)
Hmm maybe it was really something wrong with IP adress but I don;t understand, I don't use any IP configs,any firewalls.:thinking:
  • Like
Reactions: funkylogik
Upvote 0
Are you using the latest version of jellybear, 4.32 and which version of gapps are you flashing?

No,beofre flashing the ROM called "Jellybeer" I had Jelly Bean 4.1.2 version, and when I flashed this ROM I had latest jelly bean version 4.2.2

And I downloaded Gapps 20130301 version based on jelly bean 4.2.2 version and on CyanogenMod 10.1.x (which Jellybeer is based on this CM version) and I installed Gapps and Jellybeer from official developer's page.
Upvote 0
Yeah that's the correct gapps. Did you download the ROM from this page?


It looks like the ROM changed to a different dev in the team so there are two threads. The most recent version is in the link above so if you downloaded from the other page before give this one a try.

But this ROM only for Google Nexus 4 isn't it? And I've read that you can't flash a ROM based on different phone models (for example flash LG nexus 4 ROM on Galaxy S3 and etc) or you will brick your phone.
And I downloaded ROM from this page based on my GS3 I9300
  • Like
Reactions: funkylogik
Upvote 0
Hello again, guys,I found some similar articles about my problem, so in one forum I've read that it can be google services issue, and I had an issue with gapps, which always stopped working, especially when I clicked on "turn on data" and I always had "com.google.process.gapps has stopped working" so probably I got my issue,but I couldn't got how to fix it, I tried to reflash it, to make factory reset, to wipe everything, so probably it was gapps issue not ROM :)
Upvote 0
Hello guys, how are you? I tried to flash SlimBean latest Build 7 now, and I have the same issue, if I won't fix it I will finally understand that custom ROMS are abslutely not for me.:(
If openly I feel sad now that I can't use any custom ROM for this problem. :((

Edit: it's what I have got on my stock browser
authentication via proxy server was unsuccessful

How to fix it?
Upvote 0
Try going into APN settings and totally remove "proxy" then hit save. It doesnt do any harm n its worth a try :thumbup:
(Maybe take a note of the proxy setting incase you need to put it back)

Oh my God I fixed it now I can conenct to the internet!!!!!!!!!!!!!!!
I love you man, and now I'm so happy!!!!!!!!!!!!

P.S please don't delete this tread, this can be useful for more people and to me too in the future

Thanks again guys, for trying to help me :)
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.