• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.


Sep 23, 2011
My friend gave me this super cheap tablet and I didn't want to deal with changing up his email and such, so I did a factory reset. I think that bricked it,

It was working as fine as a tablet of this type could work until I reset it. Any ideas? This is what happens:

On power up, it prompts me to connect to the Internet. I successfully connect to my wireless network (or so it seems - it says "Connected"), Then I click "Next". It thinks for a couple of minutes and then comes back with an error message "Couldn't connect to the Internet."

I tried powering down and back up. I tried forgetting the network and reconnecting. I tried connected to my extender. I tried re-resetting.

IDK if I screwed up by using the pin trick the first time to rest. I used the Power Button plus Volume Up button the second time. About to try again.

Here are the options:
  • Reboot system now
  • Reboot to bootloader
  • Apply update from ADB
  • Apply update from extsd
  • Apply update from usbhost
  • Wipe data/factory reset (did this one)
  • Wipe cache partition
  • Mount/system
  • View recovery logs
  • Power off
The IRulu site is non-functioning, and there don't appear to be any updates or help files living outside of it.

IDK why I'm wasting so much time on it - just want to get it working for my new kitten. Yup. I'm that person. LOL.

Any advice or should it go to the graveyard?
Well it sounds like there's just a networking issue going on. Try restarting your table and your router and see if the some problems are occurring. A lot of people will hesitate rebooting their router with the reasoning they have other devices that aren't having any connectivity problems but networking isn't that simple. The problem you want to focus on is your tablet's connectivity.
If that doesn't solve the problem though, try restarting your tablet into its Recovery Mode (that's what you're referring to), and use the 'wipe cache partition' option. The cache partition is the operating system's cache and it 'might' be tied to your networking problems. Not likely, but worth trying as wiping the system cache doesn't delete anything vital.
If you're still having WiFi connectivity issues, if your router has the option to set up a guest network, try setting it up using just its default settings. Try connecting to that guest WiFi network and see if that make any difference.

-- Which version of Android is that tablet running? Keep in mind older versions of Android, like Jelly Bean and KitKat, are quite dated and unsupported. Even third-party developers are less likely to support apps for such out-of-date versions of Android so be careful about what you do online. There are security and privacy issues to be careful about, and don't be surprised if some online services don't even work or with reduced functionality.

-- What kind of router do you have? Is it an ISP-supplied modem/router unit or do you have your own router?
Upvote 0
Send it to the graveyard or use it as a paperweight i think. Irulu is out of business, and the Irulu servers the tablet is trying to connect to, to complete its setup are no longer there. Also I don't think there's any custom ROMs for this device available, that might have made it usable.
Ah. If it's trying to connect to iRulu servers than that explains it.

Clearly I have too much time on my hands. But I DO like a challenge!!

Found this, but it's using stock ROM
Which would get me into the same issue.

Found this:

But wouldn't I need to build a custom ROM myself? Oy. Hate throwing things away that have the potential to be fixed, If I would have known this, I would have left it as is.

Upvote 0
Your initial description of your problem appears to be network related. I'd focus on that -- flashing the ROM 'might' be a solution, if not a bit extreme, if the problem is with your tablet but if it's due to your router than you can flash your tablet's ROM a dozen times and that won't help.

And just a reminder, that tablet is old hardware running an out-of-date version of Android. Depending on your router and its configuration, WiFi connectivity might involve compromises. A newer router will be using more recent protocols so whenever you're also trying to include old devices there's an unavoidable mismatch.
  • Like
Reactions: ocnbrze
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.