• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help LEDs are on but not responding to force restart


Oct 24, 2020
Hello, here's the full story of my s7 edge in the last two days:

Yesterday, I was watching a movie and my phone was with 2%, blinking red. I let it until i finished the movie and it turned off, from the low batery. But the red light was still blinking. I connected it to the charger but no response. I even tried another charger and nothing. I then waited half an hour for the red LED to turn off, meaning drained battery. Connected it to the charger and no signal. Let it charging during the night...

In the morning, the screen had a big green 100% and the LED was green! Gr8. Tried to turn it on aaand stuck in Galaxy Logo. After trying several key combos, it entered recovery mode (passing through a blue "updating software" screen; but it was not doing any update last night). There, the infos said it could not find some path... But the menu recovery options appeared and I selected the reboot now. It turned off but not on.

I had to click the power again to turn on... Then, 15 minutes stuck in galaxy logo. More half an hour stuck in Samsung logo, while the LED was animating blue&purple. And now, the screen is black and the LED is still in the animation.

I tried all the key combos i read online, all for several time: Force reboot (v down, power); Download (v down, power, home); Recovery (v up, power, home)
But nothing works!!!

What is happening? What can I do?, all was fine yesterday.
Unfortunely, the last backup I have is not upated

The battery is huge and all charged, I cannot wait a week for this to drain again....
Last edited:
ok a couple of things. first off, your phone is over 4 years old now. phones tend to have a shelf life of about 3-4 years so you are right on that threshold. once you past that the phone will start to have issues. this is mainly due to the battery, but others things will start to happen. the phone could slow down, apps will not work anymore, or your system partitions could get corrupted.......which sounds like is what happened.

secondly, you should never run the battery completely dry like that. anything under 5% should be immediately put on the charger. so you can't get into recovery mode any more? if you can you can do a factory reset and see if it will boot after that. if not then you most likely have a corrupted partition and will need to flash a firmware update. hopefully you can get to download mode. if you can then you can try using odin to flash the firmware update.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.