• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Lost USB Mass Storage after 2.3.6 Update


Aug 10, 2012
Hello all...

I was wondering if anyone has any ideas. After my phone updated to 2.3.6 I have lost the USB Mass Storage. When I plug my phone into the computer, it pops up on my phone the option to charge, or mass storage, once I click mass storage, the next window where you enable it just disappears.

I have read on these forums to use ODIN, which I can't revert back to a previous build because my computer doesn't see my phone. It seems like all options on the forums are for people that can connect via USB Mass Storage.

My phone WAS rooted before the update, but no longer after the update.

Any ideas/help on this issue?

Do you still get the USB icon in the notification bar? Did you change any settings after the update?

I can't remember the exact command, but there's some hidden menu that allows you to change the behavior of thbe USB port. One setting is for mass storage (UTP or something like that), another is almost kind of a debug setting. Also, I don't think this is the problem, but try turning USB debug off if it's on. My phone is supposed to ask what to do when I plug it into the computer, but it doesn't anymore, and I found out it's because USB debugging is on.

If you still get the notification icon, and can access mass storage that way, it might be that the the app or whatever that handles mass storage is broken. Also, if you have or are able to get CWM back on, you can access mass storage in the "mount and unmount" option from the main menu.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.