• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root [MetroPCS/CDMA] Need Stock d2mtr ROM

Does anyone have a original d2mtr ROM that I can use to restore a SCH-R530M?

Tried installing CM10 and it stops at the CM loading screen. Like an idiot, I wiped the cache where the backup I made was.


welcome to AF!!!!!!!!!

just an fyi this is the galaxy note 3 forum.....what you want is the metro s3 root forum.....but in order for me to move this thread i need to know which version you have. is it cdma or gsm?
Upvote 0
So I got this R530M as a warranty replacement. I did the 4.1.2 update and enabled the dual app menu. I installed TWRP and backed up the ROM -- which saved to the onboard storage. I forgot to move the backup to the External SD card.

I loaded the CM 10.2 stable zip on the SD and installed with TWRP. It hung at the CM guy with the arrow spinning around it. I went to go back to the stock ROM and realized I just had wiped the cache.

I tried installing a stock ROM from http://www.shabbypenguin.com/?developer=MetroPCS_Samsung_SG3(CDMA-White) but no go. it hangs in Odin.

Not sure what to try next.
Upvote 0
o ok well the original issue was the latest version of cm does not flash in twrp, you must install cwm for it to flash properly.. you can safely flash cwm onto your device using odin, should be on that guide somewhere.. as for the "stock" rom, if you want root and have recovery access, then flash metropolis which is basically pure stock with root, or numbertwo rom which is same but with theming and little tweaks..

im not sure how far you went in odin.. but if you still have access to twrp than you can safely flash either of the roms mentioned.. i recomend wiping data and manually formating the system partition before you make your official rom choice
  • Like
Reactions: skoral and ocnbrze
Upvote 0
Does anyone have a copy of metropolis that would be willing to PM a link to me for? ShabbyPenguin's site keeps giving me a "size mismatch" error when downloading. It fails at 20-30% every time.
ill upload it for ya right now ;)but only for this purpose, im taking it down afterwars because its not my work and i dont dont want any misunderstandings.. ill post link soon as its uploaded gimme 10 min
  • Like
Reactions: ocnbrze
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.