• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.
I had this same issue, it worked when my ROM was rooted stock. I didn't use MMS when I had StarSCROM (latest version), but I know it didn't work when I was using MrRee??? ROM (latest version). I wiped my sd card, reset to factory defaults with CWM, wiped cache, wiped dalvic cache, and still no dice. I those steps once more and tried out ChevROM (latest version) and MMS still will not work. (I can send SMS messages but not MMS messages that include media of some sort.)

So factory reset didn't work, flashing a new rom didn't work, wiping cache didn't work, changing SMS/MMS apps didn't work. (I use GoMessenger, I tried using the stock messenger, but no dice there. Also, no parenthesis around the area code.)

I'd really appreciate if anyone could shed some light on this topic. My girlfriend can't send pictures to my e-mail address with her phone because it's not included with her plan. I can send pictures to her through e-mail but she has to use her computer to get at them since she cant use the internet to check her e-mail on her phone either. So yeah.... if anyone could help us out here I'd be eternally grateful.
 
Upvote 0
k guys so i am also having this problem.
i am rooted and such a noob. and i accidently deleted my messaging pak. i reinstalled with some help from another forum. so now i can receive pic messages(mms) all day long. which is great. but now for some reason i cant send them? i am pretty sure it was stock mms pak i installed but i cant promise that. can anyone please help me send my girl pics again? lol
thanks guys

ps i searched the forum for this and read a lot of suggestions before asking my question. and so far none have worked(even the above about wifi and 3g and rebooting etc)
thanks again guys
 
Upvote 0
I had this problem as well across two different ROM's. Go into Settings->Applications->Manage Applications->SMS/MMS program. You force close then clear data on everything related to your SMS/MMS. Reboot the phone. Send a test MMS.
That did it for me, clearing cache, factory reset, etc. did nothing for me. Hope this fixes your problem like it fixed mine.
 
Upvote 0
Hey on my phone when i try to send a pic messgae it just says sending and about 1 to 2 hours later it will pop up a message and it says unable to send message please help

I used to have this problem
get a file explorer... navigate to /data/data/com.android.providers.telephony/databases

Locate telephony.db and delete it, restart phone and try sending an MMS
 
Upvote 0
I had the same problem. I was unable to send pics, but could receive them. Completely stock, no flashing/rooting ever, using stock Text Messaging app. I also noticed when I clicked on the Boost ID icon that it said the Boost Network was not detected. That was the case from the beginning (had some issues when activating the phone), but since I could call/text, etc and didn't want ID packs I put it off.

I called Boost and went through the rigamarole, which led to typing in a number being led to Reset. I asked, "will this erase all of my settings and everything on my phone?" "No, we're just resetting the network" or something like that.

Of course it did reset my phone, went back to day 1 looks with tutorials on the screen and everything. Oh well, SD should have most of it. Pics are working and Boost ID connects. Hang up, and then realize my Voicemail is dialing the wrong number as my phone number is programmed wrong in the About Phone section.

Call back, fix that, number is showing correctly. Assume all is well, hang up. Find that I can't text or call at all now. Call back and go through more resets and updates. Now all better be well, because each call led to a new problem.

At least my original problem is fixed. Now I just have to recover what I can. I backed up a couple weeks ago and meant to backup right before I called, but it slipped my mind. I can see some stuff in My Files, so hopefully if I re-download an app it will be recovered (such as ColorNote notes).

Just realized, Boost ID is again saying Boost Network Not Detected. UGHHGHGHGHHHHH!!! I don't care about ID packs, but if there's any indication of something not working I want to get it fixed before I set my phone up again, lest they have me reset and lose it all again at a later date. For now I'm resting for the night, already spent over an hour and they did mention at various steps that some things would take time to reset. Wish me luck, I'll update with changes. I can still call/text and send/receive pics.

Sorry, I meant to just report how I got my problem fixed with some warnings, but it turned into a rambling.

Update: The Boost ID not detecting network is because I was on WiFi. Turn WiFi off and be on 3G and it works. So it looks like everything is working on my phone now.
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones