• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Need A Little Expert Adive Re: Google Play TF700 Infinity

Unable to download anything from Google Play.

I can surf the net. Do online banking, etc.. I have updates in the "Notification Panel" & they all download and install flawlessly,
but unable to download any apps from Google play i.e., Kindle, Overdrive, Moon Reader...Nothing.. Nada..

Device is registered. Google play shows it. I select an app, click "Install". It says "This app will be downloaded to your device shortly". I click "OK" but nothing never, ever installs. No icons shows up on the main screen and no new apps show up in apps folder in "settings".

Is me?????? What I'm I doing wrong????
Are you trying to use the web for downloading apps, or the actual google play app that came pre-loaded on the device already?

Both. I logged into Google Play with my desktop, and then with my laptop and tried to send/download to tablet while it was connected via my home WiFi connection,

and then I used the tablet and directly logged into Google Play ( my WiFi). All of the prompts were there, clicked install/Ok but download never happened.

As i said, I can surf, search, do online banking, log into Google Play, etc. but it just won't download any of the apps. The connection is there, the signal is strong. I'm just at wit's end!

It's probably me. Some people have the "Midas Touch". I have the "Murphy Touch."
Someone once said, "Life's a bitch - then you die". Well. they must've had me in mind

FYI...Tablet has been updated to JB. I tried to download apps after JB was installed. No luck. I THEN downloaded Google Play and the other assorted updates after JB was installed. Still no luck. I did a reset..No luck. I did a Cold Boot..No luck..My last resort may be a 4th Factory Reset and start anew :-(

Update: Got it to download.. Just on a whim I removed my external 64g Sandisk MicroSd card and d@mn if it didn't download.. What give here???

I've notice that I have been having all sorts of glitches on my Infinity which seems to be related to JB and Sandisk 64gb micro card

Is there anyone else having phantom problems caused by the external 64gb SanDisk card and JB or any other 64gb card???????

I had no problems w/ICS & card, just since the JB upgrade
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.