• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Need help, please! Installed Liquid GB via ROM Manager and cannot install any apps!


Sep 2, 2011
Hey all,

Final Edit:
I got things working again. I believe the last update that Google did to the Market app is what was causing problems; everything worked until the Market updated after which, *BAM* no more app installs. I booted into recovery mode and cleared the cache, and after that things were able to install again. I suspect this will work if I want to try and go back to Liquid Gingerbread, but this was such a disaster that I'm not entirely sure I care to go through that headache again. Hopefully this will at least prove helpful to somebody else out there if they run into this kind of problem.


Edit #2:
I got some of the Google Apps installed on my phone finally using Cyanogen's apps package. Unfortunately, I am about ready to cry because I am now facing the same problem under CM 7.0.2 that I was seeing after flashing to Liquid Gingerbread - the Market went through and installed some of my apps, but then went belly up and now no matter what I try to install it tells me that I have insufficient storage. I cannot believe all of this disaster just from trying to install a different ROM. :( I just want a working phone again.


I managed to boot my system into recovery mode and reinstall the CM 7 ROM that was sitting on my SD card, however I cannot get any of the Google apps back now. :( When I tried to go through ROM Manager, when I try to download the package (which I know is there, I've seen it), it says I need to update ROM Manager, and then force closes. I do not have the Market so I cannot install the most current version of ROM Manager. I downloaded a zip file from Cyanogen's site with a shit ton of APK files for the Google apps, but they will not install. I enabled third party apps, but when I tell it to install the apk, it spins for a second and then just says 'Not installed'.

I did a search for the APK of the most current version of ROM Manager, and found AN apk, but apparently it was an older version, and it just goes belly up when trying to load the list of ROMs to download. I am obviously just in over my head at this point - does anybody know how I can just get back to stock on this thing? I just want a working phone again.


I have been running CM 7.0.2 on my Droid for a while now, and decided I wanted to try out a new ROM; I had heard good things about Liquid Smooth ROMs, so installed the most current version via ROM Manager, clearing both the Dalvik cache as well as the data and cache.

The phone rebooted and recovered after the ROM install ok, and the Market started to do its thing with reinstalling apps, but at some point it decided it couldn't install anything else. I had seen this once before, and normally I could just go back in and install the missing apps manually. Unfortunately this time around, when I try to install ANY app now, the phone tells me insufficient storage!

I am nowhere near running out of room on the internal storage on the phone at this point, with over 200 MB still of available storage. I have seen a couple of suggestions but they require apps to be installed (like Root File Explorer or ES File Explorer) - and I cannot install ANYTHING!

I did not have anything like this trouble when I installed either CM 6 or CM 7 on my phone, so am fairly desperate at this point; please please please, somebody tell me they have some idea what can be done! :(

I cannot even install ROM Manager to put CM 7 BACK onto the phone. I know I made a backup of the stock ROM at one point and am seriously considering going back to it if I can figure out a way of doing it.
Glad you got it fixed, and I know I'm late, but this is why you always, always select "backup current rom" when flashing a new one. And I may be wrong to assume you didn't do so. If you did do so, the simple thing to getting your phone working again would have been to restore your backup when you booted into recovery manually instead of trying what you did in your Edit 1, i.e. installing CM7 without the gapps.

Also glad you did post all the things you did, as too many just edit their post, or post again saying, NVM, got it fixed without telling us how.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.